Add bzip2 package.
authorFelix Fietkau <nbd@openwrt.org>
Wed, 28 Nov 2007 17:22:43 +0000 (17:22 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Wed, 28 Nov 2007 17:22:43 +0000 (17:22 +0000)
Add bzip2 package.

Signed-off-by: Fabian Deutsch <fabian.deutsch@gmx.de>
SVN-Revision: 9617

utils/bzip2/Makefile [new file with mode: 0644]

diff --git a/utils/bzip2/Makefile b/utils/bzip2/Makefile
new file mode 100644 (file)
index 0000000..f49cd79
--- /dev/null
@@ -0,0 +1,56 @@
+#
+# Copyright (C) 2007 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+# $Id$
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=bzip2
+PKG_VERSION:=1.0.4
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=http://www.bzip.org/$(PKG_VERSION)/
+PKG_MD5SUM:=fc310b254f6ba5fbb5da018f04533688
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/bzip2
+  SECTION:=utils
+  CATEGORY:=Utilities
+  DEPENDS:=
+  TITLE:=bzip2 is a compression utility.
+  URL:=http://www.bzip.org/
+endef
+
+define Package/dmidecode/description
+       bzip2 is a freely available, patent free, high-quality \
+       data compressor.
+endef
+
+define Build/Configure
+       $(call Build/Configure/Default, \
+               --prefix=/usr \
+       );
+endef
+
+define Build/Compile
+       $(call Build/Compile/Default, \
+               CFLAGS="$(TARGET_CFLAGS)" \
+               LDFLAGS="$(TARGET_LDLAGS)" \
+               bzip2 \
+        )
+endef
+
+define Package/bzip2/install
+       mkdir -p $(1)/usr/bin/
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/bzip2 $(1)/usr/bin/
+endef
+
+$(eval $(call BuildPackage,bzip2))
+