ar71xx: refresh patches
authorGabor Juhos <juhosg@openwrt.org>
Thu, 10 Sep 2009 13:37:34 +0000 (13:37 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Thu, 10 Sep 2009 13:37:34 +0000 (13:37 +0000)
SVN-Revision: 17559

target/linux/ar71xx/patches-2.6.28/101-ksz8041_phy_driver.patch
target/linux/ar71xx/patches-2.6.30/003-ar71xx_usb_host.patch
target/linux/ar71xx/patches-2.6.30/110-usb-ehci-add-war-for-synopsys-hc-bug.patch
target/linux/ar71xx/patches-2.6.30/803-ar71xx-update-dsa-switch-support.patch
target/linux/ar71xx/patches-2.6.31/005-ar71xx_mac_driver.patch
target/linux/ar71xx/patches-2.6.31/803-ar71xx-update-dsa-switch-support.patch

index af3cb345e5194c707bf2007c61e24d6bafc67cfa..861a98ef161b346679e90851fd0b97575938a0a5 100644 (file)
@@ -1,7 +1,7 @@
 --- a/drivers/net/phy/Kconfig
 +++ b/drivers/net/phy/Kconfig
-@@ -88,6 +88,11 @@ config AR8216_PHY
-       tristate "Driver for Atheros AR8216 switches"
+@@ -92,6 +92,11 @@ config RTL8306_PHY
+       tristate "Driver for Realtek RTL8306S switches"
        select SWCONFIG
  
 +config MICREL_PHY
@@ -14,9 +14,9 @@
        depends on PHYLIB=y
 --- a/drivers/net/phy/Makefile
 +++ b/drivers/net/phy/Makefile
-@@ -18,6 +18,7 @@ obj-$(CONFIG_MVSWITCH_PHY)   += mvswitch.o
- obj-$(CONFIG_IP175C_PHY)      += ip175c.o
+@@ -19,6 +19,7 @@ obj-$(CONFIG_IP175C_PHY)     += ip175c.o
  obj-$(CONFIG_AR8216_PHY)      += ar8216.o
+ obj-$(CONFIG_RTL8306_PHY)     += rtl8306.o
  obj-$(CONFIG_REALTEK_PHY)     += realtek.o
 +obj-$(CONFIG_MICREL_PHY)      += micrel.o
  obj-$(CONFIG_FIXED_PHY)               += fixed.o
index 78bdba7cbebf96b75afe89d900054bfc2b079009..4a08987becab003244feec6edd34764b79c37574 100644 (file)
@@ -30,7 +30,7 @@
        depends on USB_OHCI_HCD && (STB03xxx || PPC_MPC52xx)
 --- a/drivers/usb/host/ehci-hcd.c
 +++ b/drivers/usb/host/ehci-hcd.c
-@@ -1072,6 +1072,11 @@ MODULE_LICENSE ("GPL");
+@@ -1075,6 +1075,11 @@ MODULE_LICENSE ("GPL");
  #define       PLATFORM_DRIVER         ixp4xx_ehci_driver
  #endif
  
index ff4c594a0293673ef1fa1c927210da107b8ec9d0..a34155a205b2d3aa93c3e841299ec6f4bb60e5e1 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/usb/host/ehci-q.c
 +++ b/drivers/usb/host/ehci-q.c
-@@ -1082,6 +1082,9 @@ static void end_unlink_async (struct ehc
+@@ -1127,6 +1127,9 @@ static void end_unlink_async (struct ehc
                ehci->reclaim = NULL;
                start_unlink_async (ehci, next);
        }
index d96a874ba15134debf8b482886bf8c4c3700807a..03f9dd27f4b5ad9db50b00cbaa4c005e623430da 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/ar71xx/devices.c
 +++ b/arch/mips/ar71xx/devices.c
-@@ -792,6 +792,8 @@ static struct platform_device ar71xx_dsa
+@@ -790,6 +790,8 @@ static struct platform_device ar71xx_dsa
  void __init ar71xx_add_device_dsa(unsigned int id,
                                  struct dsa_platform_data *d)
  {
@@ -9,7 +9,7 @@
        switch (id) {
        case 0:
                d->netdev = &ar71xx_eth0_device.dev;
-@@ -805,7 +807,10 @@ void __init ar71xx_add_device_dsa(unsign
+@@ -803,7 +805,10 @@ void __init ar71xx_add_device_dsa(unsign
                        id);
                return;
        }
index 1ebd790535c8e3cce1138979cf01942605f94345..043a3ec2c3e19858e8bf94a9d7f398a50757d203 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/net/Kconfig
 +++ b/drivers/net/Kconfig
-@@ -2101,6 +2101,8 @@ config ACENIC_OMIT_TIGON_I
+@@ -2103,6 +2103,8 @@ config ACENIC_OMIT_TIGON_I
  
          The safe and default value for this is N.
  
index d96a874ba15134debf8b482886bf8c4c3700807a..03f9dd27f4b5ad9db50b00cbaa4c005e623430da 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/ar71xx/devices.c
 +++ b/arch/mips/ar71xx/devices.c
-@@ -792,6 +792,8 @@ static struct platform_device ar71xx_dsa
+@@ -790,6 +790,8 @@ static struct platform_device ar71xx_dsa
  void __init ar71xx_add_device_dsa(unsigned int id,
                                  struct dsa_platform_data *d)
  {
@@ -9,7 +9,7 @@
        switch (id) {
        case 0:
                d->netdev = &ar71xx_eth0_device.dev;
-@@ -805,7 +807,10 @@ void __init ar71xx_add_device_dsa(unsign
+@@ -803,7 +805,10 @@ void __init ar71xx_add_device_dsa(unsign
                        id);
                return;
        }