package/kernel: add dependency on kmod-input-core to kmod-sound-core (closes: #7140)
authorNicolas Thill <nico@openwrt.org>
Fri, 16 Apr 2010 03:52:49 +0000 (03:52 +0000)
committerNicolas Thill <nico@openwrt.org>
Fri, 16 Apr 2010 03:52:49 +0000 (03:52 +0000)
SVN-Revision: 20901

package/kernel/modules/sound.mk

index 46bc6853ad5c407d7cce2e9d7e6d32112672b08e..a3d1486346e1305c171d4fedc0efe194539cfc3f 100644 (file)
@@ -10,7 +10,7 @@ SOUND_MENU:=Sound Support
 define KernelPackage/sound-core
   SUBMENU:=$(SOUND_MENU)
   TITLE:=Sound support
-  DEPENDS:=@AUDIO_SUPPORT
+  DEPENDS:=@AUDIO_SUPPORT +!TARGET_x86:kmod-input-core
   KCONFIG:= \
        CONFIG_SOUND \
        CONFIG_SND \