Add fixes from #1329
authorFlorian Fainelli <florian@openwrt.org>
Sun, 11 Mar 2007 11:04:57 +0000 (11:04 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Sun, 11 Mar 2007 11:04:57 +0000 (11:04 +0000)
SVN-Revision: 6552

net/ntpd/Makefile
net/ntpd/files/ntp.conf

index 181ad0e1239491a90cf0116aa3886aa7fc16094c..46075469158f5a6649f2d7432a68d363f4d4f45a 100644 (file)
@@ -60,9 +60,9 @@ define Package/ntpd/install
        $(INSTALL_DIR) $(1)/etc
        $(INSTALL_DATA) ./files/ntp.conf $(1)/etc/
        $(INSTALL_DIR) $(1)/etc/init.d
-       $(INSTALL_DATA) ./files/ntpd.init $(1)/etc/init.d/ntpd
+       $(INSTALL_BIN) ./files/ntpd.init $(1)/etc/init.d/ntpd
        $(INSTALL_DIR) $(1)/etc/hotplug.d/iface
-       $(INSTALL_DATA) ./files/ntpd.hotplug $(1)/etc/hotplug.d/iface/20-ntpd
+       $(INSTALL_BIN) ./files/ntpd.hotplug $(1)/etc/hotplug.d/iface/20-ntpd
 endef
 
 $(eval $(call BuildPackage,ntpd))
index 9b4211270b7ebe3f2bcc0310f1070fb7ebb1e12e..4d502b215d12c5e8c7079b412517be9918d9fcd9 100644 (file)
@@ -1,15 +1,19 @@
 # use a random selection of 8 public stratum 2 servers
 # see http://twiki.ntp.org/bin/view/Servers/NTPPoolServers
 
-restrict default nomodify notrap noquery
+#restrict default nomodify notrap noquery
+#restrict default noquery
+
 
 restrict 127.0.0.1
-restrict 192.168.1.253
 
 driftfile  /etc/ntp.drift
 
-server 127.127.1.0
-fudge   127.127.1.0 stratum 10
+server 0.pool.ntp.org iburst
+server 1.pool.ntp.org iburst
+server 2.pool.ntp.org iburst
+server 3.pool.ntp.org iburst
+
 
 # GPS(NMEA)+PPS
 #server 127.127.20.0 minpoll 4 prefer