backfire: ar71xx: create separate 'factory' and 'sysupgrade' images for the WRT160NL...
authorGabor Juhos <juhosg@openwrt.org>
Wed, 28 Apr 2010 10:45:56 +0000 (10:45 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Wed, 28 Apr 2010 10:45:56 +0000 (10:45 +0000)
The 'factory' image requires the garbage at the end of the image.
Flashing from the original web interface does not work without that.

SVN-Revision: 21223

target/linux/ar71xx/image/Makefile

index 4a421090b98733740655d476eb013cc63c2d647d..419dfb32d846feeb9df1c2bbb82dd80ae2515ccc 100644 (file)
@@ -299,7 +299,10 @@ define Image/Build/CyberTAN
                -x 32 -a 0x10000 -x -32 -f $(KDIR)/root.$(1)
        -$(STAGING_DIR_HOST)/bin/addpattern -B $(2) -v v$(4) \
                -i $(KDIR)/image.tmp \
                -x 32 -a 0x10000 -x -32 -f $(KDIR)/root.$(1)
        -$(STAGING_DIR_HOST)/bin/addpattern -B $(2) -v v$(4) \
                -i $(KDIR)/image.tmp \
-               -o $(call imgname,$(1),$(2)).bin
+               -o $(call imgname,$(1),$(2))-sysupgrade.bin
+       -$(STAGING_DIR_HOST)/bin/addpattern -B $(2) -v v$(4) -g \
+               -i $(KDIR)/image.tmp \
+               -o $(call imgname,$(1),$(2))-factory.bin
        rm $(KDIR)/image.tmp
 endef
 
        rm $(KDIR)/image.tmp
 endef