[packages] transmission: update to 2.30
authorCezary Jackiewicz <cezary@eko.one.pl>
Tue, 17 May 2011 05:14:39 +0000 (05:14 +0000)
committerCezary Jackiewicz <cezary@eko.one.pl>
Tue, 17 May 2011 05:14:39 +0000 (05:14 +0000)
SVN-Revision: 26914

net/transmission/Makefile
net/transmission/files/transmission.config
net/transmission/files/transmission.init

index 679a7e398641a7303759fa1b6b6e120a390db107..5fdb2b2b3ca2bdae167c394054c4fec164d9a332 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2009-2010 OpenWrt.org
+# Copyright (C) 2009-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=transmission
-PKG_VERSION:=2.22
-PKG_RELEASE:=3
+PKG_VERSION:=2.30
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://mirrors.m0k.org/transmission/files
-PKG_MD5SUM:=6499986bf769276310b00bda1090090d
+PKG_MD5SUM:=d0168d89ec48716af3c44fa21216ddc8
 
 PKG_FIXUP:=libtool
 PKG_INSTALL:=1
index 7c2a0aa9a8241707221c2ae6ff5013ad7b6913c0..c69ebc95ae9317c4d6dd2fe6e8df2ff8d0271c98 100644 (file)
@@ -59,5 +59,6 @@ config transmission
        option trash_original_torrent_files false
        option umask 18
        option upload_slots_per_torrent 14
+       option utp_enabled true
        option watch_dir_enabled false
        option watch_dir ''
index 54951782282d8f9cc15179d13ccb4b78b8af52e3..1c77d949b839f735faf19aea7d2afc6c4a643243 100644 (file)
@@ -65,7 +65,7 @@ start_service() {
                rpc_enabled rpc_port rpc_whitelist_enabled script_torrent_done_enabled \
                speed_limit_down speed_limit_down_enabled speed_limit_up \
                speed_limit_up_enabled start_added_torrents trash_original_torrent_files \
-               umask upload_slots_per_torrent watch_dir_enabled
+               umask upload_slots_per_torrent utp_enabled watch_dir_enabled
 
        append_params_quotes "$s" \
                blocklist_url bind_address_ipv4 bind_address_ipv6 download_dir incomplete_dir \
@@ -77,7 +77,7 @@ start_service() {
 
        chown -R $run_as_usr $config_dir
 
-       config_get open_file_limit "$s" open_file_limit
+       config_get open_file_limit "$s" open_file_limit 32
        let open_limit_files="$open_file_limit + 8"
 
        if [ ${open_file_limit} -gt ${ulimit_files} ]; then