[package] vpnc: use $(INSTALL_DIR) instead of a custom install call (#10957)
authorFlorian Fainelli <florian@openwrt.org>
Tue, 7 Aug 2012 16:09:12 +0000 (16:09 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Tue, 7 Aug 2012 16:09:12 +0000 (16:09 +0000)
SVN-Revision: 33042

net/vpnc/Makefile

index ad1592e15ba501655af28074ebae80461a615ac4..58af2074597aa6a087ebd82db0b5474762ce34ef 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2012 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=vpnc
 PKG_VERSION:=0.5.3
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.unix-ag.uni-kl.de/~massar/vpnc/
@@ -54,7 +54,7 @@ define Package/vpnc/install
        $(CP)   $(PKG_INSTALL_DIR)/usr/sbin/vpnc \
                $(PKG_INSTALL_DIR)/usr/sbin/vpnc-disconnect \
                $(1)/usr/sbin/
-       install -d -m0700 $(1)/etc/vpnc
+       $(INSTALL_DIR) $(1)/etc/vpnc
        $(INSTALL_CONF) $(PKG_INSTALL_DIR)/etc/vpnc/default.conf $(1)/etc/vpnc/
 endef