cleanup some of the custom work for devel libs
authorTim Yardley <lst@openwrt.org>
Sun, 26 Nov 2006 23:13:49 +0000 (23:13 +0000)
committerTim Yardley <lst@openwrt.org>
Sun, 26 Nov 2006 23:13:49 +0000 (23:13 +0000)
SVN-Revision: 5651

package/iptables/Makefile

index 862797e315a1b3d1ff9708ae71802dbde6bff67d..962ca7d0ef0aab7f9e2102d8260b25dfaab6e8ce 100644 (file)
@@ -173,7 +173,7 @@ define Build/Compile
                COPT_FLAGS="$(TARGET_CFLAGS)" \
                KERNEL_DIR="$(LINUX_DIR)" PREFIX=/usr \
                DESTDIR="$(PKG_INSTALL_DIR)" \
-               all install install-devel
+               all install
 endef
 
 define Build/InstallDev
@@ -182,13 +182,20 @@ define Build/InstallDev
                COPT_FLAGS="$(TARGET_CFLAGS)" \
                KERNEL_DIR="$(LINUX_DIR)" PREFIX=/usr \
                DESTDIR="$(STAGING_DIR)" \
-               install install-devel
+               install-devel
        $(CP) $(PKG_BUILD_DIR)/include $(STAGING_DIR)/usr
+       $(CP) $(PKG_BUILD_DIR)/libiptc/libiptc.a $(STAGING_DIR)/usr/lib
 endef
 
 define Build/UninstallDev
-       rm -rf $(STAGING_DIR)/usr/include/libipq.h
+       rm -rf $(STAGING_DIR)/usr/include/libipulog
+       rm -rf $(STAGING_DIR)/usr/include/libipq
+       rm -rf $(STAGING_DIR)/usr/include/libiptc
+       rm -rf $(STAGING_DIR)/usr/include/linux/netfilter*
+       rm -rf $(STAGING_DIR)/usr/include/iptables*
+       rm -rf $(STAGING_DIR)/usr/include/ip6tables*
        rm -rf $(STAGING_DIR)/usr/lib/libipq.a
+       rm -rf $(STAGING_DIR)/usr/lib/libiptc.a
 endef
 
 define Package/iptables/install