[package] base-files: sysupgrade: merge info from "opkg list-changed-conffiles" to...
authorJo-Philipp Wich <jow@openwrt.org>
Tue, 5 Oct 2010 07:40:25 +0000 (07:40 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Tue, 5 Oct 2010 07:40:25 +0000 (07:40 +0000)
SVN-Revision: 23233

package/base-files/Makefile
package/base-files/files/sbin/sysupgrade

index f290e79a06620976cd4ffe8d0ad7b4ae8b395246..9598823cb15c0a32a11b0037899c784112e3e64f 100644 (file)
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=base-files
-PKG_RELEASE:=57
+PKG_RELEASE:=58
 
 PKG_FILE_DEPENDS:=$(PLATFORM_DIR)/ $(GENERIC_PLATFORM_DIR)/base-files/
 PKG_BUILD_DEPENDS:=opkg/host
index 0fb07530e474dda189e6f31b1ce5b87e5bb95631..1210e6e509fdf6d64c05da030b2b5c7b303fb996 100755 (executable)
@@ -55,8 +55,9 @@ EOF
 
 add_uci_conffiles() {
        local file="$1"
-       find /etc/config /etc/passwd /etc/group /etc/dropbear \
-               /etc/firewall.user /etc/rc.local -type f > "$file"
+       ( find /etc/config /etc/passwd /etc/group /etc/dropbear \
+               /etc/firewall.user /etc/rc.local -type f;
+         opkg list-changed-conffiles ) | sort -u > "$file"
        return 0
 }