[packages_10.03.1] merge r27798, r27799
authorJo-Philipp Wich <jow@openwrt.org>
Sat, 30 Jul 2011 00:28:58 +0000 (00:28 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Sat, 30 Jul 2011 00:28:58 +0000 (00:28 +0000)
SVN-Revision: 27836

net/znc/Makefile
net/znc/patches/004-fix_memleak.patch [new file with mode: 0644]

index 1de624317878eefba0d920f1ea78cf87a27cff07..e6488db2a8f8574df5e45c9b039dba0c9070762b 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=znc
 PKG_VERSION:=0.098
-PKG_RELEASE:=2
+PKG_RELEASE:=4
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://znc.in/releases
@@ -170,10 +170,6 @@ $(eval $(call module,disconkick,This module will kick your client from all \
 
 $(eval $(call module,fail2ban,Block IPs for some time after a failed login.))
 
-$(eval $(call module,fixfreenode,This module blocks some freenode-specific \
-       feature which results in plus (+) and minus (-) signs being displayed in \
-       front of every message from a client.))
-
 $(eval $(call module,keepnick,Tries to get you your primary nick.))
 
 $(eval $(call module,kickrejoin,Implements auto-rejoin-on-kick.))
diff --git a/net/znc/patches/004-fix_memleak.patch b/net/znc/patches/004-fix_memleak.patch
new file mode 100644 (file)
index 0000000..51394c0
--- /dev/null
@@ -0,0 +1,14 @@
+--- a/Chan.cpp
++++ b/Chan.cpp
+@@ -417,9 +417,10 @@ bool CChan::AddNick(const CString& sNick
+       // Get the nick
+       sTmp   = sTmp.Token(0, false, "!");
++      CNick tmpNick(sTmp);
+       CNick* pNick = FindNick(sTmp);
+       if (!pNick) {
+-              pNick = new CNick(sTmp);
++              pNick = &tmpNick;
+               pNick->SetUser(m_pUser);
+       }