rename uvcvideo to linux-uvc (match source name)
authorNicolas Thill <nico@openwrt.org>
Thu, 20 Sep 2007 10:40:17 +0000 (10:40 +0000)
committerNicolas Thill <nico@openwrt.org>
Thu, 20 Sep 2007 10:40:17 +0000 (10:40 +0000)
SVN-Revision: 8867

package/linux-uvc/Makefile [new file with mode: 0644]
package/uvcvideo/Makefile [deleted file]

diff --git a/package/linux-uvc/Makefile b/package/linux-uvc/Makefile
new file mode 100644 (file)
index 0000000..4aa9834
--- /dev/null
@@ -0,0 +1,39 @@
+# 
+# Copyright (C) 2007 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+# $Id$
+
+include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/kernel.mk
+
+PKG_NAME:=linux-uvc
+PKG_VERSION:=r111
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=http://naaa.de/programme/linux-uvc/
+PKG_MD5SUM:=36c742d9dd1cf533fa059a1eeffa3e32
+
+include $(INCLUDE_DIR)/package.mk
+
+define KernelPackage/video-uvc
+  SUBMENU:=Video Support
+  TITLE:=USB Video Class (UVC) support
+  URL:=http://linux-uvc.berlios.de/
+  DEPENDS:=@LINUX_2_6 @USB_SUPPORT +kmod-usb-core kmod-video-core
+  FILES:=$(PKG_BUILD_DIR)/uvcvideo.$(LINUX_KMOD_SUFFIX)
+  AUTOLOAD:=$(call AutoLoad,90,uvcvideo)
+endef
+
+define Build/Compile
+       $(MAKE) -C $(LINUX_DIR) \
+               ARCH="$(LINUX_KARCH)" \
+               CROSS_COMPILE="$(TARGET_CROSS)" \
+               SUBDIRS="$(PKG_BUILD_DIR)" \
+               modules
+endef
+
+$(eval $(call KernelPackage,video-uvc))
diff --git a/package/uvcvideo/Makefile b/package/uvcvideo/Makefile
deleted file mode 100644 (file)
index 4aa9834..0000000
+++ /dev/null
@@ -1,39 +0,0 @@
-# 
-# Copyright (C) 2007 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-# $Id$
-
-include $(TOPDIR)/rules.mk
-include $(INCLUDE_DIR)/kernel.mk
-
-PKG_NAME:=linux-uvc
-PKG_VERSION:=r111
-PKG_RELEASE:=1
-
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://naaa.de/programme/linux-uvc/
-PKG_MD5SUM:=36c742d9dd1cf533fa059a1eeffa3e32
-
-include $(INCLUDE_DIR)/package.mk
-
-define KernelPackage/video-uvc
-  SUBMENU:=Video Support
-  TITLE:=USB Video Class (UVC) support
-  URL:=http://linux-uvc.berlios.de/
-  DEPENDS:=@LINUX_2_6 @USB_SUPPORT +kmod-usb-core kmod-video-core
-  FILES:=$(PKG_BUILD_DIR)/uvcvideo.$(LINUX_KMOD_SUFFIX)
-  AUTOLOAD:=$(call AutoLoad,90,uvcvideo)
-endef
-
-define Build/Compile
-       $(MAKE) -C $(LINUX_DIR) \
-               ARCH="$(LINUX_KARCH)" \
-               CROSS_COMPILE="$(TARGET_CROSS)" \
-               SUBDIRS="$(PKG_BUILD_DIR)" \
-               modules
-endef
-
-$(eval $(call KernelPackage,video-uvc))