[backfire/packages] backport [28402] (distribute) & [28403] (mako) changes
authorNicolas Thill <nico@openwrt.org>
Tue, 11 Oct 2011 07:13:51 +0000 (07:13 +0000)
committerNicolas Thill <nico@openwrt.org>
Tue, 11 Oct 2011 07:13:51 +0000 (07:13 +0000)
SVN-Revision: 28409

lang/distribute/Makefile
lang/mako/Makefile

index bae9f5c29b8ee301f2721c61f1dc850d89071834..aee3ef3ded6efa332f9eb0dd8508aa60d2a78b17 100644 (file)
@@ -41,10 +41,10 @@ define Host/Compile
 endef
 
 define Host/Install
-       $(INSTALL_DIR) $(STAGING_DIR_HOST)$(PYTHON_PKG_DIR)
+       $(INSTALL_DIR) $(STAGING_DIR)$(PYTHON_PKG_DIR)
        $(CP) \
            $(PKG_INSTALL_DIR)$(PYTHON_PKG_DIR)/* \
-           $(STAGING_DIR_HOST)$(PYTHON_PKG_DIR)
+           $(STAGING_DIR)$(PYTHON_PKG_DIR)/
 endef
 
 define Build/Compile
@@ -55,7 +55,7 @@ define Package/distribute/install
        $(INSTALL_DIR) $(1)$(PYTHON_PKG_DIR)
        $(CP) \
            $(PKG_INSTALL_DIR)$(PYTHON_PKG_DIR)/* \
-           $(1)$(PYTHON_PKG_DIR)
+           $(1)$(PYTHON_PKG_DIR)/
        $(INSTALL_DIR) $(1)/usr/bin
        $(INSTALL_BIN) \
            $(PKG_INSTALL_DIR)/usr/bin/easy_install \
index ad8f1f7c83842ea0de2fe3d9f8850bf79f8dcdd4..ad935c6c18d62db15a855833b163107593e21f76 100644 (file)
@@ -27,7 +27,7 @@ define Package/mako
   CATEGORY:=Languages
   TITLE:=Mako Templates for Python
   URL:=http://www.makotemplates.org/
-  DEPENDS:=+python @BROKEN
+  DEPENDS:=+python 
 endef
 
 define Package/mako/description
@@ -50,7 +50,7 @@ define Package/mako/install
        $(INSTALL_DIR) $(1)$(PYTHON_PKG_DIR)
        $(CP) \
            $(PKG_INSTALL_DIR)$(PYTHON_PKG_DIR)/* \
-           $(1)$(PYTHON_PKG_DIR)
+           $(1)$(PYTHON_PKG_DIR)/
 endef
 
 $(eval $(call BuildPackage,mako))