misc cosmetic fixes:
authorNicolas Thill <nico@openwrt.org>
Mon, 8 Jan 2007 11:19:08 +0000 (11:19 +0000)
committerNicolas Thill <nico@openwrt.org>
Mon, 8 Jan 2007 11:19:08 +0000 (11:19 +0000)
 * reorder PKG_* variables, Build/(Un)InstallDev macros
 * remove unneeded configure options and PKG_INSTALL_DIR stuff
 * remove dupe descriptions

SVN-Revision: 6035

31 files changed:
libs/bzip2/Makefile
libs/flac/Makefile
libs/gd/Makefile
libs/libamsel/Makefile
libs/libnet-1.0.x/Makefile
libs/libnet-1.1.x/Makefile
libs/libnids/Makefile
libs/lzo/Makefile
libs/matrixssl/Makefile
libs/uclibc++/Makefile
net/aircrack-ng/Makefile
net/amwall/Makefile
net/atftp/Makefile
net/bwm/Makefile
net/cutter/Makefile
net/ethtool/Makefile
net/fprobe-ulog/Makefile
net/fprobe/Makefile
net/frickin/Makefile
net/gpsd/Makefile
net/iperf/Makefile
net/ipkungfu/Makefile
net/netperf/Makefile
net/oidentd/Makefile
net/privoxy/Makefile
net/reaim/Makefile
net/ttcp/Makefile
net/vncrepeater/Makefile
net/vsftpd/Makefile
sound/mt-daapd/Makefile
utils/mutt/Makefile

index fa753a4dd4dc89ae916fc7af3f72e28ec5aa1aa1..af19e87bfe85b7f2239d53003241506aaabefb1d 100644 (file)
@@ -25,7 +25,7 @@ define Package/libbzip2
   SECTION:=libs
   CATEGORY:=Libraries
   TITLE:=bzip2 is a freely available, patent free, high-quality data compressor.
-  URL:=http://www.bzip.org
+  URL:=http://www.bzip.org/
 endef
 
 define Build/Compile
@@ -47,4 +47,4 @@ define Build/UninstallDev
                $(STAGING_DIR)/usr/lib/libbz2.a
 endef
 
-$(eval $(call BuildPackage,libbzip2))
+$(eval $(call Build/DefaultTargets))
index 806e9030fd25f4131505fe5bd633bc359e81b67a..2e73f849c7a769f56a2f29f11b2447e1e98a58e8 100644 (file)
@@ -12,13 +12,12 @@ PKG_NAME:=flac
 PKG_VERSION:=1.1.2
 PKG_RELEASE:=1
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/flac
 PKG_MD5SUM:=2bfc127cdda02834d0491ab531a20960
 PKG_CAT:=zcat
 
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -26,7 +25,6 @@ define Package/libflac
   SECTION:=libs
   CATEGORY:=Libraries
   TITLE:=Free Lossless Audio Codec library
-  DESCRIPTION:=Free Lossless Audio Codec (FLAC) library.
   URL:=ttp://flac.sourceforge.net/
 endef
 
@@ -34,19 +32,12 @@ define Build/Configure
 endef
 
 define Build/Compile
-       rm -rf $(PKG_INSTALL_DIR)
-       mkdir -p $(PKG_INSTALL_DIR)
        $(MAKE) -C $(PKG_BUILD_DIR) -f Makefile.lite \
                $(TARGET_CONFIGURE_OPTS) \
                RELEASE_CFLAGS="$(TARGET_CFLAGS)" \
                libFLAC
 endef
 
-define Package/libflac/install
-       $(INSTALL_DIR) $(1)/usr/lib
-       $(CP) $(PKG_BUILD_DIR)/obj/release/lib/libFLAC.so $(1)/usr/lib/
-endef
-
 define Build/InstallDev
        mkdir -p $(STAGING_DIR)/usr/include
        $(CP) $(PKG_BUILD_DIR)/include/FLAC $(STAGING_DIR)/usr/include/
@@ -60,4 +51,9 @@ define Build/UninstallDev
                $(STAGING_DIR)/usr/lib/libFLAC.{a,so}
 endef
 
+define Package/libflac/install
+       $(INSTALL_DIR) $(1)/usr/lib
+       $(CP) $(PKG_BUILD_DIR)/obj/release/lib/libFLAC.so $(1)/usr/lib/
+endef
+
 $(eval $(call BuildPackage,libflac))
index 12115fa44218b14beb4c79000e038d29eea9453e..781031159a1c6f51c413586d29926beb371ad745 100644 (file)
@@ -35,7 +35,6 @@ define Build/Configure
                --enable-shared \
                --enable-static \
                --disable-rpath \
-               --with-gnu-ld \
                --without-x \
                --without-freetype \
                --with-jpeg=$(STAGING_DIR)/usr \
@@ -65,7 +64,8 @@ define Build/InstallDev
 endef
 
 define Build/UninstallDev
-       rm -rf  $(STAGING_DIR)/usr/bin/gdlib-config \
+       rm -rf \
+               $(STAGING_DIR)/usr/bin/gdlib-config \
                $(STAGING_DIR)/usr/include/entities.h \
                $(STAGING_DIR)/usr/include/gd{,_io,cache,fontg,fontl,fontmb,fonts,fontt,fx}.h \
                $(STAGING_DIR)/usr/lib/libgd.{a,so*}
index a9933354db6fa2f5753dcade574a9e0a73b8c3f9..a0da70ca5d175d459b28ed9d26c429e36f347d72 100644 (file)
@@ -12,12 +12,12 @@ PKG_NAME:=libamsel
 PKG_VERSION:=20040621-cvs
 PKG_RELEASE:=1
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=ftp://ftp.amselinux.net/source/
 PKG_MD5SUM:=2077e620047404881a65d39c53c9917e
 PKG_CAT:=bzcat
 
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 
 include $(INCLUDE_DIR)/package.mk
@@ -26,8 +26,8 @@ define Package/libamsel
   SECTION:=libs
   CATEGORY:=Libraries
   TITLE:=The amwall library
-  DESCRIPTION:=The amwall library.\\\
-    A library for amwall configuration files.
+  DESCRIPTION:=\
+       A library for amwall configuration files.
   URL:=http://amselinux.de/
 endef
 
@@ -44,17 +44,12 @@ define Build/Compile
                all install
 endef
 
-define Package/libamsel/install
-       $(INSTALL_DIR) $(1)/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/* $(1)/usr/lib
-endef
-
 define Build/InstallDev
        mkdir -p $(STAGING_DIR)/usr/include
        $(CP) $(PKG_INSTALL_DIR)/usr/include/amsel/compat.h $(STAGING_DIR)/usr/include/
        mkdir -p $(STAGING_DIR)/usr/include/compat
-       $(CP) $(PKG_INSTALL_DIR)/usr/include/amsel/compat/queue.h $(STAGING_DIR)/usr/include/compat
-       mkdir -p $(STAGING_DIR)/usr/lib/
+       $(CP) $(PKG_INSTALL_DIR)/usr/include/amsel/compat/queue.h $(STAGING_DIR)/usr/include/compat/
+       mkdir -p $(STAGING_DIR)/usr/lib
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libamsel.so $(STAGING_DIR)/usr/lib/
 endef
        
@@ -65,4 +60,9 @@ define Build/UninstallDev
                $(STAGING_DIR)/usr/lib/libamsel.so
 endef
 
+define Package/libamsel/install
+       $(INSTALL_DIR) $(1)/usr/lib
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/* $(1)/usr/lib
+endef
+
 $(eval $(call BuildPackage,libamsel))
index 8539df3fa8b48214b1a58d85fe2550a42c3b982d..fbf45a000ac9293ff7cf7a526342bd8342ce8cc5 100644 (file)
@@ -46,7 +46,8 @@ define Build/Configure
        $(call Build/Configure/Default, \
                --enable-shared \
                --enable-static \
-               --with-pf_packet=yes, \
+               --with-pf_packet=yes \
+               , \
                ac_cv_libnet_endianess=$(ENDIANESS) \
                ac_libnet_have_pf_packet=yes \
        )
index 057cc6060d7e829b5657ac87f3b2d9b8c92d9724..a8c204095a0416b3e569caeac228a0b298eab30c 100644 (file)
@@ -46,7 +46,8 @@ define Build/Configure
        $(call Build/Configure/Default, \
                --enable-shared \
                --enable-static \
-               --with-pf_packet=yes, \
+               --with-pf_packet=yes \
+               , \
                ac_cv_libnet_endianess=$(ENDIANESS) \
                ac_libnet_have_pf_packet=yes \
                ac_libnet_have_packet_socket=yes \
index faf5c95ecddae15e12c0dee1a5fc4e854443f7b9..13650dbddab5580b1ba41d3754b4f6ba54cb7e31 100644 (file)
@@ -12,12 +12,12 @@ PKG_NAME:=libnids
 PKG_VERSION:=1.18
 PKG_RELEASE:=1
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.packetfactory.net/projects/libnids/dist/
 PKG_MD5SUM:=9ee6dcdfac97bae6fe611aa27d2594a5
 PKG_CAT:=zcat
 
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 
 include $(INCLUDE_DIR)/package.mk
@@ -35,12 +35,12 @@ endef
 
 define Build/Configure
        $(call Build/Configure/Default, \
-                       --enable-shared \
-                       --enable-static \
-                       --with-libnet="$(STAGING_DIR)/usr/lib/libnet-1.0.x" \
-                       --with-libpcap="$(STAGING_DIR)/usr" \
-                       , \
-                       CFLAGS="$$$$CFLAGS $$$$CPPFLAGS" \
+               --enable-shared \
+               --enable-static \
+               --with-libnet="$(STAGING_DIR)/usr/lib/libnet-1.0.x" \
+               --with-libpcap="$(STAGING_DIR)/usr" \
+               , \
+               CFLAGS="$$$$CFLAGS $$$$CPPFLAGS" \
        )
 endef
 
@@ -60,7 +60,8 @@ define Build/InstallDev
 endef
 
 define Build/UninstallDev
-       rm -rf  $(STAGING_DIR)/usr/include/nids.h \
+       rm -rf \
+               $(STAGING_DIR)/usr/include/nids.h \
                $(STAGING_DIR)/usr/lib/libnids.{a,so*}
 endef
 
index 18b04c6f0155973ffec92c5a411792157ef7bb33..5b640928104bff5c354b8aeddaa4026a5464e7e3 100644 (file)
@@ -58,7 +58,7 @@ endef
 
 define Package/liblzo/install
        $(INSTALL_DIR) $(1)/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/liblzo2.so.* $(1)/usr/lib
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/liblzo2.so.* $(1)/usr/lib/
 endef
 
 $(eval $(call BuildPackage,liblzo))
index 47d5cb4a8edf255ac6989af51e0b22c770609b2c..90c9d1807cec3b963d0542c0a4c11b886d48fb4b 100644 (file)
@@ -40,10 +40,10 @@ endef
 
 define Build/InstallDev
        mkdir -p $(STAGING_DIR)/usr/include/matrixSsl
-       $(CP) $(PKG_BUILD_DIR)/matrixSsl.h $(STAGING_DIR)/usr/include/matrixSsl
+       $(CP) $(PKG_BUILD_DIR)/matrixSsl.h $(STAGING_DIR)/usr/include/matrixSsl/
        ln -sf matrixSsl/matrixSsl.h $(STAGING_DIR)/usr/include/matrixSsl.h
        mkdir -p $(STAGING_DIR)/usr/lib
-       $(CP) $(PKG_BUILD_DIR)/src/libmatrixssl.so* $(STAGING_DIR)/usr/lib
+       $(CP) $(PKG_BUILD_DIR)/src/libmatrixssl.so* $(STAGING_DIR)/usr/lib/
 endef
 
 define Build/UninstallDev
index 1ce921439ac995efd58683bf047e5e6a607b686a..7fb1ccb682b69e801226613bff0ba1353bab1e38 100644 (file)
@@ -12,12 +12,13 @@ PKG_NAME:=uclibc++
 PKG_VERSION:=0.2.1
 PKG_RELEASE:=1
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/uClibc++-$(PKG_VERSION)
 PKG_SOURCE:=uClibc++-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://cxx.uclibc.org/src/
 PKG_MD5SUM:=6e6032c49916b199ffe6a585552fd46b
 PKG_CAT:=bzcat
 
+PKG_BUILD_DIR:=$(BUILD_DIR)/uClibc++-$(PKG_VERSION)
+
 include $(INCLUDE_DIR)/package.mk
 
 define Package/uclibcxx
@@ -25,21 +26,20 @@ define Package/uclibcxx
   SECTION:=libs
   CATEGORY:=Libraries
   TITLE:=C++ library for embedded systems
-  DESCRIPTION:=A standard C++ library for embedded systems
   URL:=http://cxx.uclibc.org/src/
 endef
 
 UCLIBC_TARGET_ARCH:=$(shell echo $(ARCH) | sed -e s'/-.*//' \
-                -e 's/i.86/i386/' \
-                -e 's/sparc.*/sparc/' \
-                -e 's/m68k.*/m68k/' \
-                -e 's/ppc/powerpc/g' \
-                -e 's/v850.*/v850/g' \
-                -e 's/sh64/sh/' \
-                -e 's/sh[234].*/sh/' \
-                -e 's/mips.*/mips/' \
-                -e 's/mipsel.*/mips/' \
-                -e 's/cris.*/cris/' \
+       -e 's/i.86/i386/' \
+       -e 's/sparc.*/sparc/' \
+       -e 's/m68k.*/m68k/' \
+       -e 's/ppc/powerpc/g' \
+       -e 's/v850.*/v850/g' \
+       -e 's/sh64/sh/' \
+       -e 's/sh[234].*/sh/' \
+       -e 's/mips.*/mips/' \
+       -e 's/mipsel.*/mips/' \
+       -e 's/cris.*/cris/' \
 )
 
 define Build/Configure
@@ -56,12 +56,6 @@ define Build/Compile
                all
 endef
 
-define Package/uclibcxx/install
-       $(INSTALL_DIR) $(1)/lib
-       $(CP) $(PKG_BUILD_DIR)/src/libuClibc++*.so.* $(1)/lib/
-       $(CP) $(PKG_BUILD_DIR)/src/libuClibc++-*.so $(1)/lib/
-endef
-
 define Build/InstallDev
        mkdir -p $(STAGING_DIR)/usr/include
        $(MAKE) -C $(PKG_BUILD_DIR) \
@@ -77,4 +71,10 @@ define Build/UninstallDev
        rm -rf $(STAGING_DIR)/lib/libuClibc++*.{a,so*}
 endef
 
+define Package/uclibcxx/install
+       $(INSTALL_DIR) $(1)/lib
+       $(CP) $(PKG_BUILD_DIR)/src/libuClibc++*.so.* $(1)/lib/
+       $(CP) $(PKG_BUILD_DIR)/src/libuClibc++-*.so $(1)/lib/
+endef
+
 $(eval $(call BuildPackage,uclibcxx))
index e1777449d991620d5ad8fecfbe9f2adb29f0e29c..a1215b0a2b1dcec0ceea3480593ca31fda2759b7 100644 (file)
@@ -26,8 +26,8 @@ define Package/aircrack-ng
   SECTION:=net
   CATEGORY:=Network
   DEPENDS:=+libpthread
-  TITLE:=Aircrack-ng the next generation of aircrack with new features
-  URL:=http://www.aircrack-ng.org
+  TITLE:=Aircrack-ng is the next generation of aircrack with new features
+  URL:=http://www.aircrack-ng.org/
 endef
 
 define Build/Configure
@@ -41,7 +41,7 @@ define Build/Compile
                CFLAGS="$(TARGET_CFLAGS) -Wall" \
                prefix="/usr" \
                destdir="$(PKG_INSTALL_DIR)" \
-       all install
+               all install
 endef
 
 define Package/aircrack-ng/install
index 4a1d983cec827b6e8e4159d509328d981563d11c..f2c696fe582b4c7962aa348fec19c49100fc1122 100644 (file)
@@ -27,7 +27,7 @@ define Package/amwall
   CATEGORY:=Network
   DEPENDS:=+libamsel
   TITLE:=PF to iptables
-  URL:=http://www.amselinux.net
+  URL:=http://www.amselinux.net/
 endef
 
 define Build/Compile
@@ -36,7 +36,7 @@ define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
                $(TARGET_CONFIGURE_OPTS) \
                V= \
-               LDIR=$(PKG_BUILD_DIR) \
+               LDIR="$(PKG_BUILD_DIR)" \
                AMSEL_INCLUDE="$(STAGING_DIR)/usr/include" \
                OPT_LDFLAGS="-L$(STAGING_DIR)/usr/lib" \
                PREFIX="/usr" \
@@ -47,11 +47,11 @@ endef
 
 define Package/amwall/install
        $(INSTALL_DIR) $(1)/usr/bin
-       $(CP) $(PKG_INSTALL_DIR)/usr/bin/* $(1)/usr/bin
+       $(CP) $(PKG_INSTALL_DIR)/usr/bin/* $(1)/usr/bin/
        $(INSTALL_DIR) $(1)/usr/sbin
-       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/* $(1)/usr/sbin
+       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/* $(1)/usr/sbin/
        $(INSTALL_DIR) $(1)/etc/amsel
-       $(CP) $(PKG_INSTALL_DIR)/etc/amsel* $(1)/etc
+       $(CP) $(PKG_INSTALL_DIR)/etc/amsel* $(1)/etc/
 endef
 
 $(eval $(call BuildPackage,amwall))
index 4c5e1d9f5ba7ef5781c26e0edb7bff2bcdff1e4a..03c2a811db88b4ad24359d591b8f3bf1d0b7df0f 100644 (file)
@@ -19,7 +19,6 @@ PKG_CAT:=zcat
 TAR_OPTIONS += || true
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -64,7 +63,7 @@ endef
 
 define Package/atftp/install
        $(INSTALL_DIR) $(1)/usr/sbin
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/atftp $(1)/usr/sbin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/atftp $(1)/usr/sbin/
 endef
 
 define Package/atftpd/install
index a58c5cbf43a9cfd173e998697c007d962a332496..8012d7bf95e95b805fe6c63cc9513d8896621694 100644 (file)
@@ -33,8 +33,8 @@ define Build/Compile
 endef
 
 define Package/bwm/install
-       mkdir -p $(1)/usr/bin
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/$(PKG_NAME) $(1)/usr/bin/
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/bwm $(1)/usr/bin/
 endef
 
 $(eval $(call BuildPackage,bwm))
index 2b99a551a96ff13cbf68b8576d3103cb60cfff5f..1e2f44c019471a7c3b6b81a61043b7653e6a68d6 100644 (file)
@@ -18,7 +18,6 @@ PKG_MD5SUM:=50093db9b64277643969ee75b83ebbd1
 PKG_CAT:=zcat
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -35,13 +34,11 @@ endef
        
 define Build/Compile
        $(TARGET_CC) $(PKG_BUILD_DIR)/cutter.c -o $(PKG_BUILD_DIR)/cutter
-       $(INSTALL_DIR) $(PKG_INSTALL_DIR)/usr/sbin
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/cutter $(PKG_INSTALL_DIR)/usr/sbin/
 endef
        
 define Package/cutter/install
        $(INSTALL_DIR) $(1)/usr/sbin
-       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/cutter $(1)/usr/sbin/
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/cutter $(1)/usr/sbin/
 endef
 
 $(eval $(call BuildPackage,cutter))
index f7b5799c27bca6d1670d917f486055de2b9996e4..0dfd624f1a8aaa6c84c4c35643ccf42db5b27914 100644 (file)
@@ -41,7 +41,7 @@ endef
 
 define Package/ethtool/install
        $(INSTALL_DIR) $(1)/usr/sbin
-       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/* $(1)/usr/sbin
+       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/ethtool $(1)/usr/sbin/
 endef
 
 $(eval $(call BuildPackage,ethtool))
index cdec7c65ff23888382b118246027b8a84e1a0394..9710e153e5451972ca12042e3f8893866f826f8e 100644 (file)
@@ -45,8 +45,8 @@ define Build/Compile
 endef
 
 define Package/fprobe-ulog/install     
-       mkdir -p $(1)/usr/bin
-       $(CP) $(PKG_BUILD_DIR)/src/fprobe-ulog $(1)/usr/bin/
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/src/fprobe-ulog $(1)/usr/bin/
 endef
 
 $(eval $(call BuildPackage,fprobe-ulog))
index 726445f24c9eae3385cf8d8e0bd5a5e494314a94..2b9306837a91cacd40390b693d2f0e7f74936b8c 100644 (file)
@@ -45,7 +45,7 @@ endef
 
 define Package/fprobe/install
        $(INSTALL_DIR) $(1)/usr/bin
-       $(CP) $(PKG_BUILD_DIR)/src/fprobe $(1)/usr/bin/
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/src/fprobe $(1)/usr/bin/
 endef
 
 $(eval $(call BuildPackage,fprobe))
index 0a266833c11d11d322055baed2408b298a7149d9..2f311fc290f627bf1fc7fbc99bdfc927add4700e 100644 (file)
@@ -18,7 +18,6 @@ PKG_MD5SUM:= 5b2e98da2310c71c703d4617b88a173f
 PKG_CAT:=zcat
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -30,7 +29,7 @@ define Package/frickin
        Frickin PPTP Proxy allows a Point-to-Point Tunneling Protocol (PPTP) \\\
        client to connect to a PPTP server through Network Address \\\
        Translation (NAT).
-  URL:=http://frickin.sourceforge.net
+  URL:=http://frickin.sourceforge.net/
 endef
 
 define Package/frickin/conffiles
index 883a274de69683bed540ed88780647662bf8cb4d..bd6189ceae3651d4f3d9d0addef01c5613b30b5c 100644 (file)
@@ -29,6 +29,7 @@ define Package/gpsd
   CATEGORY:=Network
   DEPENDS:=+libpthread +uclibcxx
   TITLE:=An interface daemon for GPS receivers
+  URL:=http://gpsd.berlios.de/
 endef
 
 define Build/Configure
index 47b012651ded41c5220a2191111a69e69c6ec7da..714b32d85a175bb7048ba3e703de45f9d757f73d 100644 (file)
@@ -52,7 +52,7 @@ endef
 
 define Package/iperf/install   
        $(INSTALL_DIR) $(1)/usr/bin
-       $(CP) $(PKG_INSTALL_DIR)/usr/bin/iperf $(1)/usr/bin
+       $(CP) $(PKG_INSTALL_DIR)/usr/bin/iperf $(1)/usr/bin/
 endef
 
 $(eval $(call BuildPackage,iperf))
index 19723bb0388823be1b66edbc89e6b26caf84c084..c6df3d78b7f733c15c0d4b04eec660cccd090f71 100644 (file)
@@ -30,7 +30,7 @@ define Package/ipkungfu
        IPKungFu is an iptables-based Linux firewall.\\\
        It aims to simplify the configuration of Internet \\\
        connection sharing, port forwarding, and packet filtering.
-  URL:=http://www.linuxkungfu.org
+  URL:=http://www.linuxkungfu.org/
 endef
 
 define Package/ipkungfu/conffiles
index 82f176df53c6301d25ade32ae55c84b8abbc0c88..75766818cac4f376299e797ed5e3faf0970c594c 100644 (file)
@@ -25,8 +25,8 @@ include $(INCLUDE_DIR)/package.mk
 define Package/netperf
   SECTION:=net
   CATEGORY:=Network
-  TITLE:=network performance measurement tool
-  URL:=http://www.netperf.org
+  TITLE:=Network performance measurement tool
+  URL:=http://www.netperf.org/
 endef
 
 define Build/Compile   
index 5aa4ae88a1bdc611b7b11f1dd1cfb9ae6ad04a48..edbe0f4596c36749b41195fcaad478307663ba02 100644 (file)
@@ -38,7 +38,7 @@ endef
 
 define Package/oidentd/install
        $(INSTALL_DIR) $(1)/usr/sbin
-       $(CP) $(PKG_BUILD_DIR)/src/$(PKG_NAME) $(1)/usr/sbin/
+       $(CP) $(PKG_BUILD_DIR)/src/oidentd $(1)/usr/sbin/
        $(INSTALL_DIR) $(1)/etc/init.d
        $(CP) ./files/oidentd.init $(1)/etc/init.d/oidentd
 endef
index 659ae9ec70dce86a813ccd2ebe727cde981374b7..04813699b328ede0228d6a4036846d5451b57963 100644 (file)
@@ -11,10 +11,10 @@ include $(TOPDIR)/rules.mk
 PKG_NAME:=privoxy
 PKG_VERSION:=3.0.3
 PKG_RELEASE:=1
-PKG_MD5SUM:=b0710be8af09409bfb03f52523a17010
 
-PKG_SOURCE_URL:=@SF/ijbswa
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-stable-src.tar.gz
+PKG_SOURCE_URL:=@SF/ijbswa
+PKG_MD5SUM:=b0710be8af09409bfb03f52523a17010
 PKG_CAT:=zcat
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)-stable
@@ -27,12 +27,13 @@ define Package/privoxy
   CATEGORY:=Network
   DEPENDS:=+libpcre +libpthread
   TITLE:=web proxy with advanced filtering capabilities
-  DESCRIPTION:=Privoxy is a web proxy with advanced filtering capabilities for\\\
-       protecting privacy, modifying web page content, managing cookies,\\\
-       controlling access, and removing ads, banners, pop-ups and other\\\
-       obnoxious Internet junk. Privoxy has a very flexible configuration\\\
-       and can be customized to suit individual needs and tastes. Privoxy\\\
-       has application for both stand-alone systems and multi-user networks.\\\
+  DESCRIPTION:=\
+       Privoxy is a web proxy with advanced filtering capabilities for \\\
+       protecting privacy, modifying web page content, managing cookies, \\\
+       controlling access, and removing ads, banners, pop-ups and other \\\
+       obnoxious Internet junk. Privoxy has a very flexible configuration \\\
+       and can be customized to suit individual needs and tastes. Privoxy \\\
+       has application for both stand-alone systems and multi-user networks.
   URL:=http://www.privoxy.org/
 endef
 
index e4c63ed613448e8656ac17eca70c1b170e69e1ce..8f90aa452f8ca4cf3bc5e39db6ade7f452de1e05 100644 (file)
@@ -28,7 +28,7 @@ define Package/reaim
   DEPENDS:=+iptables
   TITLE:=A transparent AIM / MSN proxy
   DESCRIPTION:=ReAIM is a proxy for file transfers with MSN/AIM.
-  URL:=http://reaim.sourceforge.net
+  URL:=http://reaim.sourceforge.net/
 endef
 
 define Build/Compile   
index 0028742258c48d35a97ae66b9fd15ed1434fa4f5..7f3f53d9775d27f69405e552265cd825626d46a0 100644 (file)
@@ -20,7 +20,8 @@ define Package/ttcp
   SECTION:=net
   CATEGORY:=Network
   TITLE:=A TCP connection performance tester
-  DESCRIPTION:=A small utility to test TCP connection performance
+  DESCRIPTION:=\
+       A small utility to test TCP connection performance.
   URL:=https://dev.openwrt.org/browser/packages/net/ttcp/
 endef
 
index 9c97486271a4907707d0103ed59e824a49e381d6..b1d36772b89ec66280b7de04823ce4951609d975 100644 (file)
@@ -18,7 +18,6 @@ PKG_MD5SUM:=5951740a8a103d7d9668558b3639c6c4
 PKG_CAT:=zcat
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 
 include $(INCLUDE_DIR)/package.mk
 
index 90a2b429bd1309fa9cfb00864b571b1b1ac1adf6..5c4aaa77c05e0792120b8a7045bbc6151ae10447 100644 (file)
@@ -12,12 +12,12 @@ PKG_NAME:=vsftpd
 PKG_VERSION:=2.0.4
 PKG_RELEASE:=1
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=ftp://vsftpd.beasts.org/users/cevans/
 PKG_MD5SUM:=c0bf8c7b8e15ab15827172786fc56115
 PKG_CAT:=zcat
 
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 
 include $(INCLUDE_DIR)/package.mk
index 798ef59891da30b0fc357287568a7705949172cd..23144e90d717a67ce250440571a5e4a28d36677b 100644 (file)
@@ -29,7 +29,7 @@ define Package/mt-daapd
   TITLE:=A multi-threaded DAAP (Digital Audio Access Protocol) daemon
   DESCRIPTION:=\
        mt-daapd is a program which acts as an iTunes (DAAP) server for Linux.
-  URL:=http://www.mt-daapd.org
+  URL:=http://www.mt-daapd.org/
 endef
 
 define Package/mt-daapd/conffiles
index 1a83d6e6fab7f67e3e3c8a6e16c669eb93ad7ce9..8528b36390f496512e7df16fe473a929f7fbb30f 100644 (file)
@@ -26,7 +26,7 @@ define Package/mutt
   CATEGORY:=Utilities
   DEPENDS:=+libopenssl +libncurses
   TITLE:=Console mail client
-  URL:=http://www.mutt.org
+  URL:=http://www.mutt.org/
 endef
 
 define Build/Configure