[package] add support for the sn9c102 video chips (#3976)
authorFlorian Fainelli <florian@openwrt.org>
Sat, 25 Jul 2009 23:41:22 +0000 (23:41 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Sat, 25 Jul 2009 23:41:22 +0000 (23:41 +0000)
SVN-Revision: 16991

package/kernel/modules/video.mk

index 5fd008bb706334b9116ccff4c0ce006482477010..f8b7a491ca4740b4bba30b156358977a183b5f36 100644 (file)
@@ -126,6 +126,24 @@ endef
 $(eval $(call KernelPackage,video-ovcamchip))
 
 
+define KernelPackage/video-sn9c102
+  SUBMENU:=$(VIDEO_MENU)
+  TITLE:=SN9C102 Camera Chip support
+  DEPENDS:=@LINUX_2_6 @USB_SUPPORT +kmod-usb-core +kmod-video-core
+  KCONFIG:=CONFIG_USB_SN9C102
+  FILES:=$(LINUX_DIR)/drivers/media/video/sn9c102/sn9c102.$(LINUX_KMOD_SUFFIX)
+  AUTOLOAD:=$(call AutoLoad,70,sn9c102)
+endef
+
+
+define KernelPackage/video-sn9c102/description
+ Kernel modules for supporting SN9C102
+ camera chips.
+endef
+
+$(eval $(call KernelPackage,video-sn9c102))
+
+
 define KernelPackage/video-pwc
   SUBMENU:=$(VIDEO_MENU)
   TITLE:=Philips USB webcam support