[package] update babel to 0.96, babel executable was renamed to babeld
authorFlorian Fainelli <florian@openwrt.org>
Sun, 23 Aug 2009 11:26:33 +0000 (11:26 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Sun, 23 Aug 2009 11:26:33 +0000 (11:26 +0000)
SVN-Revision: 17355

net/babel/Makefile
net/babel/files/babel.init

index 4a371f599f4557f01bb5437e0a2c195feb382a5b..e66104650e27207a0923e97e49356557304224a8 100644 (file)
@@ -7,13 +7,13 @@
 
 include $(TOPDIR)/rules.mk
 
-PKG_NAME:=babel
-PKG_VERSION:=0.95
-PKG_RELEASE:=2
+PKG_NAME:=babeld
+PKG_VERSION:=0.96
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.pps.jussieu.fr/~jch/software/files/
-PKG_MD5SUM:=942094c35acf850235d60831bb0dca38
+PKG_MD5SUM:=fdb1949237ec99cd978222fe872c4f0b
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -45,7 +45,7 @@ MAKE_FLAGS += \
 
 define Package/babel/install
        $(INSTALL_DIR) $(1)/usr/sbin
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/babel $(1)/usr/sbin/
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/babeld $(1)/usr/sbin/
        $(INSTALL_DIR) $(1)/etc
        $(INSTALL_CONF) ./files/babel.conf $(1)/etc/
        $(INSTALL_DIR) $(1)/etc/init.d
index 9e116574ad232f928aba0d93a399d8aa4e04e0f3..41c0aa1e80d98eed2839c6a6cc94dce5c89207ff 100755 (executable)
@@ -2,7 +2,7 @@
 
 START=70
 
-pidfile=/var/run/babel.pid
+pidfile=/var/run/babeld.pid
 
 babel_config() {
        local cfg="$1"
@@ -20,7 +20,7 @@ start() {
        if [ -e $pidfile ] ; then
                echo "$pidfile exists -- not starting babel." >&2
        else
-               /usr/sbin/babel -D -I $pidfile $interfaces
+               /usr/sbin/babeld -D -I $pidfile $interfaces
        fi
 }