[coova-chilli]: add some compile time options (more to come)
authorImre Kaloz <kaloz@openwrt.org>
Fri, 11 Oct 2013 13:20:27 +0000 (13:20 +0000)
committerImre Kaloz <kaloz@openwrt.org>
Fri, 11 Oct 2013 13:20:27 +0000 (13:20 +0000)
Signed-off-by: Imre Kaloz <kaloz@openwrt.org>
SVN-Revision: 38363

net/coova-chilli/Config.in [new file with mode: 0644]
net/coova-chilli/Makefile

diff --git a/net/coova-chilli/Config.in b/net/coova-chilli/Config.in
new file mode 100644 (file)
index 0000000..392c6dc
--- /dev/null
@@ -0,0 +1,26 @@
+# CoovaChilli avanced configuration
+
+menu "Configuration"
+       depends on PACKAGE_coova-chilli
+
+config COOVACHILLI_REDIR
+       bool "Enable support for redir server. Required for uamregex"
+       default n
+
+config COOVACHILLI_MINIPORTAL
+       bool "Enable support Coova miniportal"
+       default n
+
+config COOVACHILLI_USERAGENT
+       bool "Enable recording user-agent"
+       default n
+
+config COOVACHILLI_DNSLOG
+       bool "Enable support to log DNS name queries"
+       default n
+
+config COOVACHILLI_UAMDOMAINFILE
+       bool "Enable loading of mass uamdomains from file"
+       default n
+
+endmenu
index 7079799eea5b66a4a331146b811b23a4ac2c148c..83353fe836125aedc4c017b2f741b8d64efcfafe 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=coova-chilli
 PKG_VERSION:=1.3.0
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://ap.coova.org/chilli
@@ -17,6 +17,13 @@ PKG_MD5SUM:=dc0037e3cdebcb60508081b4e42e984a
 
 PKG_INSTALL:=1
 
+PKG_CONFIG_DEPENDS := \
+  COOVACHILLI_MINIPORTAL \
+  COOVACHILLI_REDIR \
+  COOVACHILLI_USERAGENT \
+  COOVACHILLI_DNSLOG \
+  COOVACHILLI_UAMDOMAINFILE
+
 include $(INCLUDE_DIR)/package.mk
 
 define Package/coova-chilli
@@ -26,6 +33,8 @@ define Package/coova-chilli
   DEPENDS:=+kmod-tun +librt
   TITLE:=Wireless LAN HotSpot controller (Coova Chilli Version)
   URL:=http://www.coova.org/CoovaChilli
+  MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
+  MENU:=1
 endef
 
 define Package/coova-chilli/description
@@ -38,6 +47,20 @@ define Package/coova-chilli/description
        favorite radius server.
 endef
 
+define Package/coova-chilli/config
+  source "$(SOURCE)/Config.in"
+endef
+
+define Build/Configure
+       $(call Build/Configure/Default, \
+       $(if $(CONFIG_COOVACHILLI_REDIR),--enable,--disable)-chilliredir \
+       $(if $(CONFIG_COOVACHILLI_DNSLOG),--enable,--disable)-dnslog \
+       $(if $(CONFIG_COOVACHILLI_MINIPORTAL),--enable,--disable)-miniportal \
+       $(if $(CONFIG_COOVACHILLI_USERAGENT),--enable,--disable)-useragent \
+       $(if $(CONFIG_COOVACHILLI_UAMDOMAINFILE),--enable,--disable)-uamdomainfile \
+       )
+endef
+
 define Package/coova-chilli/conffiles
 /etc/chilli.conf
 endef