added gtk-1.2 package
authorJohn Crispin <john@openwrt.org>
Fri, 21 Sep 2007 17:15:29 +0000 (17:15 +0000)
committerJohn Crispin <john@openwrt.org>
Fri, 21 Sep 2007 17:15:29 +0000 (17:15 +0000)
SVN-Revision: 8923

XOrg/app/gtk-1.2.10/Makefile [new file with mode: 0644]

diff --git a/XOrg/app/gtk-1.2.10/Makefile b/XOrg/app/gtk-1.2.10/Makefile
new file mode 100644 (file)
index 0000000..0e3c436
--- /dev/null
@@ -0,0 +1,60 @@
+# 
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+# blogic@openwrt.org
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=gtk-1.2.10
+PKG_VERSION:=1.2.10
+PKG_RELEASE:=1
+
+PKG_SOURCE:=gtk+-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=http://gd.tuwien.ac.at/graphics/gimp/gtk/v1.2/
+PKG_BUILD_DIR=$(BUILD_DIR)/gtk+-1.2.10
+
+include $(INCLUDE_DIR)/package.mk
+
+CONFIGURE_ARGS_XTRA+=--x-includes=$(STAGING_DIR)/usr/include/ \
+               --x-libraries=$(STAGING_DIR)/usr/lib \
+               --with-glib-prefix=$(STAGING_DIR)/usr/ \
+               --enable-static=yes \
+               --enable-static=yes
+
+EXTRA_CFLAGS+=-Wl,-rpath-link=$(STAGING_DIR)/usr/lib
+
+EXTRA_LDFLAGS+=-lnotimpl
+
+define Package/gtk-1.2.10
+  SECTION:=xorg-framework
+  CATEGORY:=Xorg
+  SUBMENU:=framework
+  TITLE:=GTK+ 1.2.10 package
+  DEPENDS:=glib1
+endef
+
+define Build/Configure
+       (cd $(PKG_BUILD_DIR)/$(CONFIGURE_PATH); \
+               if [ -x $(CONFIGURE_CMD) ]; then \
+                       $(CP) $(SCRIPT_DIR)/config.{guess,sub} $(PKG_BUILD_DIR)/ && \
+                       $(CONFIGURE_VARS) \
+                       $(CONFIGURE_CMD) \
+                       $(CONFIGURE_ARGS_XTRA) \
+                       $(CONFIGURE_ARGS) ;\
+               fi \
+       )
+endef
+
+define Build/Compile
+       $(MAKE) -C $(PKG_BUILD_DIR)
+       $(MAKE) -C $(PKG_BUILD_DIR)/ install DESTDIR=$(PKG_INSTALL_DIR)
+endef
+
+define Build/InstallDev
+       $(CP) $(PKG_INSTALL_DIR)/* $(STAGING_DIR)/
+endef
+
+$(eval $(call BuildPackage,gtk-1.2.10))