brcm2708: fix kmod-sound-soc-bcm2708-i2s config
authorJohn Crispin <john@openwrt.org>
Mon, 5 Oct 2015 10:27:18 +0000 (10:27 +0000)
committerJohn Crispin <john@openwrt.org>
Mon, 5 Oct 2015 10:27:18 +0000 (10:27 +0000)
Right now, selecting kmod-sound-soc-bcm2708-i2s causes build errors due to
missing configs.
kmod-regmap enables I2C and SPI, causing build errors due to depending
variables not defined.

Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
SVN-Revision: 47123

target/linux/brcm2708/modules.mk

index 68a7d38028df214c51b2f46bf2c87e7fa95b2845..9c201d09972cdf65deebe33e5da23076de142325 100644 (file)
@@ -28,6 +28,8 @@ $(eval $(call KernelPackage,sound-arm-bcm2835))
 define KernelPackage/sound-soc-bcm2708-i2s
   TITLE:=SoC Audio support for the Broadcom 2708 I2S module
   KCONFIG:= \
+       CONFIG_BCM2708_SPIDEV=n \
+       CONFIG_MFD_RPISENSE_CORE=n \
        CONFIG_SND_BCM2708_SOC_I2S \
        CONFIG_SND_SOC_DMAENGINE_PCM=y \
        CONFIG_SND_SOC_GENERIC_DMAENGINE_PCM=y