[packages] add lcdproc - a piece of software that displays real-time system informati...
authorJo-Philipp Wich <jow@openwrt.org>
Sun, 5 Sep 2010 22:18:30 +0000 (22:18 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Sun, 5 Sep 2010 22:18:30 +0000 (22:18 +0000)
SVN-Revision: 22941

utils/lcdproc/Makefile [new file with mode: 0644]
utils/lcdproc/files/LCDd [new file with mode: 0755]
utils/lcdproc/files/lcdexec [new file with mode: 0755]
utils/lcdproc/files/lcdproc [new file with mode: 0755]
utils/lcdproc/files/lcdvc [new file with mode: 0755]

diff --git a/utils/lcdproc/Makefile b/utils/lcdproc/Makefile
new file mode 100644 (file)
index 0000000..d627ee2
--- /dev/null
@@ -0,0 +1,61 @@
+#
+# Copyright (C) 2007 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=lcdproc
+PKG_VERSION:=0.5.2
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=@SF/lcdproc
+PKG_MD5SUM:=860f192d061d87dda6512b11b79daac2
+
+include $(INCLUDE_DIR)/package.mk
+
+
+define Package/lcdproc
+       SECTION:=utils
+       CATEGORY:=Utilities
+       DEPENDS:=+libusb +libncurses
+       TITLE:=LCD Display daemon and client
+       URL:=http://sourceforge.net/projects/lcdproc/
+endef
+
+define Package/lcdproc/description
+ LCDProc is a daemon and client for displaying system information on various displays.
+endef
+
+define Package/lcdproc/conffiles
+/etc/LCDd.conf
+/etc/lcdproc.conf
+/etc/lcdexec.conf
+/etc/lcdvc.conf
+endef
+
+define Build/Configure
+       $(call Build/Configure/Default,--enable-drivers=all)
+endef
+
+define Package/lcdproc/install
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_DIR) $(1)/usr/lib/lcdproc
+       $(INSTALL_DIR) $(1)/etc
+       $(INSTALL_DIR) $(1)/etc/init.d
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/server/LCDd $(1)/usr/sbin/
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/clients/lcdproc/lcdproc $(1)/usr/bin/
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/clients/lcdexec/lcdexec $(1)/usr/bin/
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/clients/lcdvc/lcdvc $(1)/usr/bin/
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/server/drivers/*.so $(1)/usr/lib/lcdproc/
+       $(INSTALL_CONF) $(PKG_BUILD_DIR)/LCDd.conf $(1)/etc/
+       $(INSTALL_CONF) $(PKG_BUILD_DIR)/clients/lcdproc/lcdproc.conf $(1)/etc/
+       $(INSTALL_CONF) $(PKG_BUILD_DIR)/clients/lcdexec/lcdexec.conf $(1)/etc/
+       $(INSTALL_CONF) $(PKG_BUILD_DIR)/clients/lcdvc/lcdvc.conf $(1)/etc/
+       $(INSTALL_BIN) ./files/* $(1)/etc/init.d
+endef
+
+$(eval $(call BuildPackage,lcdproc))
diff --git a/utils/lcdproc/files/LCDd b/utils/lcdproc/files/LCDd
new file mode 100755 (executable)
index 0000000..5bec7bc
--- /dev/null
@@ -0,0 +1,11 @@
+#!/bin/sh /etc/rc.common 
+
+START=50
+
+start() {
+       LCDd -c /etc/LCDd.conf
+}
+
+stop() {
+       killall LCDd
+}
diff --git a/utils/lcdproc/files/lcdexec b/utils/lcdproc/files/lcdexec
new file mode 100755 (executable)
index 0000000..0d5a3f3
--- /dev/null
@@ -0,0 +1,11 @@
+#!/bin/sh /etc/rc.common. 
+
+START=50
+
+start() {
+       lcdexec -c /etc/lcdexec.conf
+}
+
+stop() {
+       killall lcdexec
+}
diff --git a/utils/lcdproc/files/lcdproc b/utils/lcdproc/files/lcdproc
new file mode 100755 (executable)
index 0000000..eb86134
--- /dev/null
@@ -0,0 +1,11 @@
+#!/bin/sh /etc/rc.common. 
+
+START=50
+
+start() {
+       lcdproc -c /etc/lcdproc.conf
+}
+
+stop() {
+       killall lcdproc
+}
diff --git a/utils/lcdproc/files/lcdvc b/utils/lcdproc/files/lcdvc
new file mode 100755 (executable)
index 0000000..026fd04
--- /dev/null
@@ -0,0 +1,11 @@
+#!/bin/sh /etc/rc.common. 
+
+START=50
+
+start() {
+       lcdvc -c /etc/lcdvc.conf
+}
+
+stop() {
+       killall lcdvc
+}