[packages] net/freeswitch: Use /usr/share/freeswitch as prefix; this means freeswitch...
authorDaniel Dickinson <crazycshore@gmail.com>
Tue, 24 Aug 2010 13:21:40 +0000 (13:21 +0000)
committerDaniel Dickinson <crazycshore@gmail.com>
Tue, 24 Aug 2010 13:21:40 +0000 (13:21 +0000)
  Modify the configuration so that recordings are stored on /var/lib/freeswitch/recordings by default (this is a tmpfs so should be change if persistance is needed).
  Allow the scripts and htdocs to have their directories set individually instead of requirings them to be under /usr/share/freeswitch.

SVN-Revision: 22783

net/freeswitch/Makefile

index a36ef1ac39ee2a38a766ca2f078f66071b6835cb..fc7efb823a44339df7bff831a964893ded02bcdb 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=freeswitch
 PKG_VERSION:=1.0.6
-PKG_RELEASE:=10
+PKG_RELEASE:=11
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
@@ -304,7 +304,7 @@ FS_TARGET_CXXFLAGS:= ${TARGET_CXXFLAGS} -DLUA_USE_LINUX $(FPIC) -Wno-format
 FS_TARGET_CPPFLAGS:= -I. -I./lua ${TARGET_CPPFLAGS}
 
 CONFIGURE_ARGS+= \
-       --prefix="/usr/freeswitch" \
+       --prefix="/usr/share/freeswitch" \
        --bindir="/usr/bin" \
        --libdir="/usr/lib" \
        --sysconfdir="/etc/freeswitch" \
@@ -385,7 +385,7 @@ endef
 
 define Build/InstallDev
        $(INSTALL_DIR) $(1)/usr/include/freeswitch
-       $(CP) $(PKG_INSTALL_DIR)/usr/freeswitch/include/* $(1)/usr/include/freeswitch/
+       $(CP) $(PKG_INSTALL_DIR)/usr/share/freeswitch/include/* $(1)/usr/include/freeswitch/
        $(INSTALL_DIR) $(1)/usr/lib
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libfreeswitch.{a,so*} $(1)/usr/lib/
 endef
@@ -434,13 +434,13 @@ define Package/freeswitch-config-minimal/install
 endef
 
 define Package/freeswitch-sounds-en/install
-       $(INSTALL_DIR) $(1)/usr/freeswitch/sounds
-       $(CP) $(PKG_INSTALL_DIR)/usr/freeswitch/sounds/en $(1)/usr/freeswitch/sounds/
+       $(INSTALL_DIR) $(1)/usr/share/freeswitch/sounds
+       $(CP) $(PKG_INSTALL_DIR)/usr/share/freeswitch/sounds/en $(1)/usr/share/freeswitch/sounds/
 endef
 
 define Package/freeswitch-sounds-moh/install
-       $(INSTALL_DIR) $(1)/usr/freeswitch/sounds
-       $(CP) $(PKG_INSTALL_DIR)/usr/freeswitch/sounds/music $(1)/usr/freeswitch/sounds/
+       $(INSTALL_DIR) $(1)/usr/share/freeswitch/sounds
+       $(CP) $(PKG_INSTALL_DIR)/usr/share/freeswitch/sounds/music $(1)/usr/share/freeswitch/sounds/
 endef
 
 define Package/freeswitch-tools/install