[packages] luaexpat: fix compile error triggered by cs toolchain
authorJo-Philipp Wich <jow@openwrt.org>
Tue, 27 Oct 2009 23:43:23 +0000 (23:43 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Tue, 27 Oct 2009 23:43:23 +0000 (23:43 +0000)
SVN-Revision: 18192

lang/luaexpat/Makefile
lang/luaexpat/patches/001-compile-fix.patch [new file with mode: 0644]

index 05dd6573e135566ecd1486f35e1b0c1c78015038..a0dc1c261288e55edcfc553622e863d7e68bb213 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=luaexpat
 PKG_VERSION:=1.1
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://luaforge.net/frs/download.php/2469
@@ -41,7 +41,7 @@ define Build/Compile
        LUA_LIBDIR="$(STAGING_DIR)/usr/lib/" \
        COMPAT_DIR="$(PKG_BUILD_DIR)/compat-5.1r5" \
        LIB_OPTION="-shared $(TARGET_LDFLAGS)" \
-       CC="$(TARGET_CC) $(TARGET_CFLAGS)" \
+       CC="$(TARGET_CC) $(TARGET_CFLAGS) -std=c99" \
        LD="$(TARGET_CROSS)ld -shared" 
 endef
 
diff --git a/lang/luaexpat/patches/001-compile-fix.patch b/lang/luaexpat/patches/001-compile-fix.patch
new file mode 100644 (file)
index 0000000..c2e863a
--- /dev/null
@@ -0,0 +1,10 @@
+--- a/config
++++ b/config
+@@ -31,6 +31,6 @@
+         -Wshadow \
+         -Wwrite-strings
+-CFLAGS = $(CWARNS) -ansi -O2 -I$(LUA_INC) \
++CFLAGS = $(CWARNS) -O2 -I$(LUA_INC) \
+    -I$(COMPAT_DIR) -I$(EXPAT_INC)
+ CC = gcc