[package] iptables: don't use /bin/bash in autogen.sh, breaks FreeBSD. Also move...
authorJo-Philipp Wich <jow@openwrt.org>
Sat, 9 Oct 2010 17:47:55 +0000 (17:47 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Sat, 9 Oct 2010 17:47:55 +0000 (17:47 +0000)
SVN-Revision: 23369

package/iptables/Makefile
package/iptables/patches/100-bash-location.patch [new file with mode: 0644]

index 8609b6d7c4e26ed4bb47e8f0b92ce8823202551c..e637771871f8abf69b6aae17d1c94d1e716cf4d5 100644 (file)
@@ -305,9 +305,9 @@ MAKE_FLAGS := \
        KERNEL_DIR="$(LINUX_DIR)" PREFIX=/usr \
        KBUILD_OUTPUT="$(LINUX_DIR)" \
 
-define Build/Prepare
-$(call Build/Prepare/Default)
+define Build/Configure
        (cd $(PKG_BUILD_DIR); ./autogen.sh)
+$(call Build/Configure/Default)
 endef
 
 define Build/InstallDev
diff --git a/package/iptables/patches/100-bash-location.patch b/package/iptables/patches/100-bash-location.patch
new file mode 100644 (file)
index 0000000..818246e
--- /dev/null
@@ -0,0 +1,16 @@
+--- a/autogen.sh
++++ b/autogen.sh
+@@ -1,4 +1,4 @@
+-#!/bin/bash
++#!/usr/bin/env bash
+ autoreconf -fi;
+ rm -Rf autom4te*.cache;
+--- a/iptables-apply
++++ b/iptables-apply
+@@ -1,4 +1,4 @@
+-#!/bin/bash
++#!/usr/bin/env bash
+ #
+ # iptables-apply -- a safer way to update iptables remotely
+ #