make the rest of the structure for the targets that dont have profiles yet
authorTim Yardley <lst@openwrt.org>
Sat, 3 Mar 2007 01:22:09 +0000 (01:22 +0000)
committerTim Yardley <lst@openwrt.org>
Sat, 3 Mar 2007 01:22:09 +0000 (01:22 +0000)
SVN-Revision: 6475

target/linux/aruba-2.6/Makefile
target/linux/atheros-2.6/Makefile
target/linux/brcm47xx-2.6/Makefile
target/linux/ixp4xx-2.6/Makefile
target/linux/magicbox-2.6/Makefile
target/linux/pxa-2.6/Makefile
target/linux/rb532-2.6/Makefile
target/linux/sibyte-2.6/Makefile
target/linux/uml-2.6/Makefile
target/linux/x86-2.6/Makefile

index 5d3e19ea2f514fdba1c16ec41250cd5b0d7e872a..c53964da8ac9feffeb49701c050fc0988444369f 100644 (file)
@@ -18,4 +18,7 @@ endef
 include $(INCLUDE_DIR)/kernel-build.mk
 DEFAULT_PACKAGES += kmod-madwifi
 
+# include the profiles
+-include profiles/*.mk
+
 $(eval $(call BuildKernel))
index 5404902f37eeaeff2a9a9b70808e78f65050471f..1700dec8c6d48b4901e4805bbb249b953e6d82eb 100644 (file)
@@ -18,4 +18,7 @@ endef
 include $(INCLUDE_DIR)/kernel-build.mk
 DEFAULT_PACKAGES += kmod-madwifi
 
+# include the profiles
+-include profiles/*.mk
+
 $(eval $(call BuildKernel))
index ca7fd5d2d1cbdf54834693e997686598f1e895fc..ab79d82908a047e1fabac3b41d447a8e3a211fd9 100644 (file)
@@ -19,4 +19,7 @@ endef
 include $(INCLUDE_DIR)/kernel-build.mk
 # DEFAULT_PACKAGES += kmod-switch
 
+# include the profiles
+-include profiles/*.mk
+
 $(eval $(call BuildKernel))
index 352671ee69e6d63593eca6d92bbdeed941f41b16..5eea6d62584d432d0653c6d3d3cdc5b2fc7197af 100644 (file)
@@ -15,4 +15,8 @@ define Target/Description
 endef
 
 include $(INCLUDE_DIR)/kernel-build.mk
+
+# include the profiles
+-include profiles/*.mk
+
 $(eval $(call BuildKernel))
index b829965a50e3afc600e6649123a5d8414ababbed..20325a8fa66169a505f72190217c9a51f23c1a91 100644 (file)
@@ -12,4 +12,8 @@ BOARDNAME:=Magicbox
 FEATURES:=jffs2
 
 include $(INCLUDE_DIR)/kernel-build.mk
+
+# include the profiles
+-include profiles/*.mk
+
 $(eval $(call BuildKernel))
index 94e9601b92a8281494a4de6d15a37ade9941e19f..76ca28e37c089ca7ebe2e513b76b6565a58619a3 100644 (file)
@@ -17,4 +17,7 @@ endef
 
 include $(INCLUDE_DIR)/kernel-build.mk
 
+# include the profiles
+-include profiles/*.mk
+
 $(eval $(call BuildKernel))
index 6ec9bdcd38f25c81287827ffdb3318986928c718..27569a35db228dbe53a70d32340d3c3cb6e1b078 100644 (file)
@@ -12,4 +12,8 @@ BOARDNAME:=Mikrotik RouterBoard 532
 FEATURES:=jffs2
 
 include $(INCLUDE_DIR)/kernel-build.mk
+
+# include the profiles
+-include profiles/*.mk
+
 $(eval $(call BuildKernel))
index 364d116d4d4593057a2697e9d777bacf4610dca0..28b3302750754554ba32f4eddeb5fffab07c40a4 100644 (file)
@@ -12,4 +12,8 @@ BOARDNAME:=SiByte MIPS
 FEATURES:=broken
 
 include $(INCLUDE_DIR)/kernel-build.mk
+
+# include the profiles
+-include profiles/*.mk
+
 $(eval $(call BuildKernel))
index 25624108ab30dfaf82dbdd561a4c526f7a09a856..089ef585819ba84285026f807e7e7a0a10b85aa8 100644 (file)
@@ -24,6 +24,10 @@ FEATURES:=broken
 LINUX_CONFIG:=$(CURDIR)/config/$(ARCH)
 
 include $(INCLUDE_DIR)/kernel-build.mk
+
+# include the profiles
+-include profiles/*.mk
+
 endif
 
 $(eval $(call BuildKernel))
index 2b8e497c908bc09a194eb973d06f29da46c98d88..00533968912a98ae8a58f5fe15f1270475feca0f 100644 (file)
@@ -14,5 +14,8 @@ FEATURES:=squashfs jffs2 ext2
 include $(INCLUDE_DIR)/kernel-build.mk
 DEFAULT_PACKAGES += kmod-natsemi
 
+# include the profiles
+-include profiles/*.mk
+
 $(eval $(call BuildKernel))