libnl-tiny: install pkgconfig file
authorRosen Penev <rosenp@gmail.com>
Mon, 10 Feb 2020 05:21:09 +0000 (21:21 -0800)
committerPetr Štetiar <ynezz@true.cz>
Sat, 11 Jul 2020 11:42:34 +0000 (13:42 +0200)
This will allow getting rid of InstallDev in the Makefile.

It also allows compilation with CMAKE_BINARY_SUBDIR.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
CMakeLists.txt

index 10bf4e8558b6614cd4c35927db287dc092db49a4..581015cbbd250a84820d393d4ef5a598f45ef768 100644 (file)
@@ -32,6 +32,7 @@ CONFIGURE_FILE(
 )
 
 INSTALL(TARGETS nl-tiny LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR})
+INSTALL(FILES ${CMAKE_BINARY_DIR}/libnl-tiny.pc DESTINATION ${CMAKE_INSTALL_LIBDIR}/pkgconfig)
 INSTALL(
        DIRECTORY ${CMAKE_SOURCE_DIR}/include/
        DESTINATION ${CMAKE_INSTALL_INCLUDEDIR}/libnl-tiny