cmake: enable extra compiler checks
authorPetr Štetiar <ynezz@true.cz>
Fri, 4 Oct 2019 14:43:05 +0000 (16:43 +0200)
committerPetr Štetiar <ynezz@true.cz>
Tue, 29 Oct 2019 21:16:00 +0000 (22:16 +0100)
Let's enforce additional automatic checks enforced by the compiler in
order to catch possible errors during compilation.

Signed-off-by: Petr Štetiar <ynezz@true.cz>
CMakeLists.txt

index a81727dc1b60de2f05b0f6bf951faf71f59a4b11..10bf4e8558b6614cd4c35927db287dc092db49a4 100644 (file)
@@ -5,7 +5,7 @@ INCLUDE(GNUInstallDirs)
 
 INCLUDE_DIRECTORIES(include)
 
-ADD_DEFINITIONS(-Wall -Werror)
+ADD_DEFINITIONS(-Wall -Werror -Wextra -Wno-unused-parameter)
 STRING(REPLACE "-DNDEBUG" "" CMAKE_C_FLAGS_RELEASE "${CMAKE_C_FLAGS_RELEASE}")
 
 ADD_LIBRARY(nl-tiny SHARED