treewide: add explicit Lua runtime dependencies where needed
authorJo-Philipp Wich <jo@mein.io>
Wed, 19 Oct 2022 18:39:57 +0000 (20:39 +0200)
committerJo-Philipp Wich <jo@mein.io>
Mon, 24 Oct 2022 23:03:37 +0000 (01:03 +0200)
Some packages require Lua libraries but do not ship with a luasrc directory,
add explicit dependencies in these cases.

Signed-off-by: Jo-Philipp Wich <jo@mein.io>
applications/luci-app-ddns/Makefile
applications/luci-app-splash/Makefile
libs/luci-lib-px5g/Makefile
protocols/luci-proto-openconnect/Makefile
protocols/luci-proto-openfortivpn/Makefile

index a529e22e227bc9c977f2517e4d7042ca7036abf6..2ebb0c8b82b8e053e0cd91cbcafebb42fa1c53b8 100644 (file)
@@ -12,7 +12,7 @@ PKG_LICENSE:=Apache-2.0
 PKG_MAINTAINER:=Ansuel Smith <ansuelsmth@gmail.com>
 
 LUCI_TITLE:=LuCI Support for Dynamic DNS Client (ddns-scripts)
-LUCI_DEPENDS:=+luci-mod-admin-full +ddns-scripts
+LUCI_DEPENDS:=+luci-mod-admin-full +luci-lua-runtime +ddns-scripts
 LUCI_PKGARCH:=all
 
 include ../../luci.mk
index db9117225fa685ed7310bf15a5da6ec17a6fd6f1..8950a497ea2276f8498a4eef100b620431e29eb4 100644 (file)
@@ -7,7 +7,7 @@
 include $(TOPDIR)/rules.mk
 
 LUCI_TITLE:=Freifunk DHCP-Splash application
-LUCI_DEPENDS:=+luci-compat +luci-lib-nixio +luci-lib-iptparser +tc +kmod-sched +iptables-mod-nat-extra +iptables-mod-ipopt
+LUCI_DEPENDS:=+luci-compat +luci-lib-nixio +luci-lib-iptparser +luci-lua-runtime +tc +kmod-sched +iptables-mod-nat-extra +iptables-mod-ipopt
 
 define Package/luci-app-splash/conffiles
 /etc/config/luci_splash
index eefee107e84f99b92418a950b67dd2eb671f9591..1c77a5c601897678efc8cba96b91d8ee91725315 100644 (file)
@@ -7,7 +7,7 @@
 include $(TOPDIR)/rules.mk
 
 LUCI_TITLE:=RSA/X.509 Key Generator (required for LuCId SSL support)
-LUCI_DEPENDS:=+liblua
+LUCI_DEPENDS:=+lua +luci-lib-nixio
 
 PKG_USE_MIPS16:=0
 PKG_LICENSE:=LGPL-2.1
index 31f52749b93dab02415199b031fe3f8e9793ff2a..9f12bcdedf4fd6bc9dc17907b967f3e0e08805aa 100644 (file)
@@ -7,7 +7,7 @@
 include $(TOPDIR)/rules.mk
 
 LUCI_TITLE:=Support for OpenConnect VPN
-LUCI_DEPENDS:=+openconnect
+LUCI_DEPENDS:=+openconnect +luci-lua-runtime
 
 include ../../luci.mk
 
index 17a63f78ebb276a4f2618339717c1499f2b441d3..fbdad18b3b4906d487c388865c6fb12b2aaed511 100644 (file)
@@ -7,7 +7,7 @@
 include $(TOPDIR)/rules.mk
 
 LUCI_TITLE:=Support for OpenFortivpn
-LUCI_DEPENDS:=+openfortivpn
+LUCI_DEPENDS:=+openfortivpn +luci-lua-runtime
 
 include ../../luci.mk