luci-app-pbr: bugfixes 6260/head
authorStan Grishin <stangri@melmac.ca>
Thu, 23 Feb 2023 21:38:07 +0000 (21:38 +0000)
committerStan Grishin <stangri@melmac.ca>
Thu, 23 Feb 2023 21:48:13 +0000 (21:48 +0000)
* do not remove non-empty custom user files fields
* add provides for vpnbypass and vpn-policy-routing luci apps
  addresses https://github.com/openwrt/luci/pull/6127#pullrequestreview-1311512052

Signed-off-by: Stan Grishin <stangri@melmac.ca>
applications/luci-app-pbr/Makefile
applications/luci-app-pbr/htdocs/luci-static/resources/view/pbr/overview.js
applications/luci-app-pbr/po/templates/pbr.pot

index 1d7eeeddab9ed30db6cced7644cf4b9131e17242..e5f88c44dccf3abe5116f2de300fe529c7091f40 100644 (file)
@@ -5,13 +5,15 @@ include $(TOPDIR)/rules.mk
 
 PKG_LICENSE:=GPL-3.0-or-later
 PKG_MAINTAINER:=Stan Grishin <stangri@melmac.ca>
-PKG_VERSION:=1.0.1-10
+PKG_VERSION:=1.1.0-1
 
 LUCI_TITLE:=Policy Based Routing Service Web UI
 LUCI_DESCRIPTION:=Provides Web UI for Policy Based Routing Service.
 LUCI_DEPENDS:=+luci-base +jsonfilter +pbr
 LUCI_PKGARCH:=all
 
+PKG_PROVIDES:=luci-app-vpnbypass luci-app-vpn-policy-routing
+
 include ../../luci.mk
 
 # call BuildPackage - OpenWrt buildroot signature
index e2d9d7b9b22ad1a35e0d0299e1512cab8e3be417..5ddf263a1e89a58d5b17d8099c7a73b679ccd0e0 100644 (file)
@@ -267,10 +267,12 @@ return view.extend({
                        o = s.option(form.Flag, "enabled", _("Enabled"));
                        o.optional = false;
                        o.editable = true;
+                       o.rmempty = false;
 
                        o = s.option(form.Value, "path", _("Path"));
                        o.optional = false;
                        o.editable = true;
+                       o.rmempty = false;
 
                        return Promise.all([status.render(), m.render()]);
                })
index f8959174e81755089a94edcb23f558abab0472c8..f8827ce5438eef2a1caeeae600c9abfdc322333f 100644 (file)
@@ -240,7 +240,7 @@ msgstr ""
 msgid "Output verbosity"
 msgstr ""
 
-#: applications/luci-app-pbr/htdocs/luci-static/resources/view/pbr/overview.js:271
+#: applications/luci-app-pbr/htdocs/luci-static/resources/view/pbr/overview.js:272
 msgid "Path"
 msgstr ""