luci-0.11: merge r9571 - r9573
authorJo-Philipp Wich <jow@openwrt.org>
Sat, 29 Dec 2012 13:15:53 +0000 (13:15 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Sat, 29 Dec 2012 13:15:53 +0000 (13:15 +0000)
applications/luci-polipo/root/usr/sbin/polipo_purge
contrib/uhttpd/patches/001-pass-env.patch
contrib/uhttpd/patches/002-link-order.patch [new file with mode: 0644]
contrib/uhttpd/patches/series
po/ca/upnp.po
po/de/upnp.po
po/en/upnp.po
po/es/upnp.po
po/pt/upnp.po
po/pt_BR/upnp.po
po/vi/upnp.po

index ce7c88559bac8bef29b922a6c3605ef1983fcaa4..23ba5719272917e25cff5acb038380ec7b13b9ab 100755 (executable)
@@ -5,7 +5,7 @@ PIDFILE=`uci get polipo.daemon.pidFile`
 CFGFILE=/var/etc/polipo.conf
 
 [ -e "$PIDFILE" ] && {
-       PID=`cat $PID_FILE`
+       PID=`cat $PIDFILE`
 
        # send Polipo USR1 signal to write its in-memory cache to disk
        kill -USR1 $PID
index b69ff176532aeb737ccd5eae657ce0e3314c8fe1..ab607dbf2d726f90b08359e6b369a5270990432f 100644 (file)
@@ -1,7 +1,7 @@
 --- a/uhttpd-cgi.c
 +++ b/uhttpd-cgi.c
-@@ -204,7 +204,7 @@ void uh_cgi_request(struct client *cl, s
-                           (pi->stat.st_mode & S_IXOTH)
+@@ -216,7 +216,7 @@ void uh_cgi_request(
+                            (pi->stat.st_mode & S_IXOTH)) || (ip != NULL)
                        ) {
                                /* build environment */
 -                              clearenv();
diff --git a/contrib/uhttpd/patches/002-link-order.patch b/contrib/uhttpd/patches/002-link-order.patch
new file mode 100644 (file)
index 0000000..8bdd335
--- /dev/null
@@ -0,0 +1,11 @@
+--- a/Makefile
++++ b/Makefile
+@@ -70,7 +70,7 @@ endif
+       $(CC) $(CFLAGS) -c -o $@ $<
+ compile: $(OBJ) $(TLSLIB) $(LUALIB)
+-      $(CC) -o uhttpd $(LDFLAGS) $(LIB) $(OBJ)
++      $(CC) -o uhttpd $(LDFLAGS) $(OBJ) $(LIB)
+ clean:
+       rm -f *.o *.so uhttpd
index dc852df8b08a0f946261da22d28fd26f1a37fbe7..8a1834ecf818412912fbed1ea958ca8393f29442 100644 (file)
@@ -1 +1,2 @@
 001-pass-env.patch
+002-link-order.patch
index 393a5629984d0febeb7554596c549b686d26786a..ad0f40867150abeb2fbe0b1aff9219fd07d5554a 100644 (file)
@@ -139,7 +139,7 @@ msgid "UPnP lease file"
 msgstr ""
 
 msgid "Universal Plug & Play"
-msgstr "Universal Plug &amp; Play"
+msgstr "Universal Plug & Play"
 
 msgid "Uplink"
 msgstr "Enllaç de pujada"
index acfdb65fb14cbee4b36ce2f26171ffb2e93dac4d..7c7ec082fe439b51d95d9fd1bfbc0c0b718c9823 100644 (file)
@@ -143,7 +143,7 @@ msgid "UPnP lease file"
 msgstr "UPnP Lease-Datei"
 
 msgid "Universal Plug & Play"
-msgstr "Universal Plug &amp; Play"
+msgstr "Universal Plug & Play"
 
 msgid "Uplink"
 msgstr "Uplink"
index 25e374d9ecd5525383f0ce6ad0a3ac65b85427fe..0afabe26a1fa42c7555a660fb3be24621db959f4 100644 (file)
@@ -138,7 +138,7 @@ msgid "UPnP lease file"
 msgstr ""
 
 msgid "Universal Plug & Play"
-msgstr "Universal Plug &amp; Play"
+msgstr "Universal Plug & Play"
 
 msgid "Uplink"
 msgstr "Uplink"
index 975ad1a58a65de67ccd6a9b2f6ee6c1c533077fb..3ad9b01d0886ede1958be4dcf00fbd04bcdcd168 100644 (file)
@@ -143,7 +143,7 @@ msgid "UPnP lease file"
 msgstr "Tiempo de cesión UPnP"
 
 msgid "Universal Plug & Play"
-msgstr "Plug &amp; Play universal"
+msgstr "Plug & Play universal"
 
 msgid "Uplink"
 msgstr "Enlace de subida"
index 2a0992ca7a28cde867df39d31498a89b401071ed..ea74caf5cf9592147332669b13ae2cca0898e464 100644 (file)
@@ -137,7 +137,7 @@ msgid "UPnP lease file"
 msgstr ""
 
 msgid "Universal Plug & Play"
-msgstr "Plug &amp; Play Universal"
+msgstr "Plug & Play Universal"
 
 msgid "Uplink"
 msgstr "Link para Upload"
index 049604d12d72b98671224df8b9019dda7f28da92..9df27ee74a3c8a1f1947a8b58694b3c33cbc6732 100644 (file)
@@ -143,7 +143,7 @@ msgid "UPnP lease file"
 msgstr "Arquivo de concessão do UPnP"
 
 msgid "Universal Plug & Play"
-msgstr "Plug &amp; Play Universal"
+msgstr "Plug & Play Universal"
 
 msgid "Uplink"
 msgstr "Velocidade de envio do enlace (uplink)"
index cb2b54e9a345a2e2c5a98a41ad7b90c5a710ae3d..f13b14b46e73dc824f511ba7c5d43c72c0fe4ab7 100644 (file)
@@ -138,7 +138,7 @@ msgid "UPnP lease file"
 msgstr ""
 
 msgid "Universal Plug & Play"
-msgstr "Universal Plug &amp; Play"
+msgstr "Universal Plug & Play"
 
 msgid "Uplink"
 msgstr "Uplink"