luci-app-statistics: Add cpu and memory plugins to the default set
authorHannu Nyman <hannu.nyman@iki.fi>
Sun, 4 Sep 2016 10:18:59 +0000 (13:18 +0300)
committerHannu Nyman <hannu.nyman@iki.fi>
Sun, 4 Sep 2016 10:18:59 +0000 (13:18 +0300)
Add cpu and memory statistics plugins to the default set included
in Luci statistics and enable them in the default config. They are
useful small collectd plugins for resource usage monitoring.

Signed-off-by: Hannu Nyman <hannu.nyman@iki.fi>
applications/luci-app-statistics/Makefile
applications/luci-app-statistics/root/etc/config/luci_statistics

index af07cfbd02116f34c8244df839811476a89a861c..6c0121e96a649afb410ec011f48a7998f2263be0 100644 (file)
@@ -9,6 +9,7 @@ include $(TOPDIR)/rules.mk
 LUCI_TITLE:=LuCI Statistics Application
 LUCI_DEPENDS:= \
        +collectd +rrdtool1 +collectd-mod-rrdtool +collectd-mod-iwinfo \
+       +collectd-mod-cpu +collectd-mod-memory \
        +collectd-mod-interface +collectd-mod-load +collectd-mod-network
 
 include ../../luci.mk
index de16f29de9eaee8fb41cc25c013c05bc982263c1..4435d5c61e05ff88aaed09bab4af78121e5d70de 100644 (file)
@@ -53,7 +53,7 @@ config statistics 'collectd_conntrack'
        option enable '0'
 
 config statistics 'collectd_cpu'
-       option enable '0'
+       option enable '1'
 
 config statistics 'collectd_df'
        option enable '0'
@@ -113,7 +113,7 @@ config statistics 'collectd_load'
        option enable '1'
 
 config statistics 'collectd_memory'
-       option enable '0'
+       option enable '1'
 
 config statistics 'collectd_netlink'
        option enable '0'