ramips: sound-mt7620: fix dependencies for kernel 4.9
authorMathias Kresin <dev@kresin.me>
Fri, 7 Jul 2017 05:56:24 +0000 (07:56 +0200)
committerMathias Kresin <dev@kresin.me>
Fri, 7 Jul 2017 05:56:24 +0000 (07:56 +0200)
With kernel 4.8 common used code was moved to a shared kmod. Add the
missing dependency to the shared snd-soc-simple-card-utils.ko.

Signed-off-by: Mathias Kresin <dev@kresin.me>
target/linux/ramips/modules.mk

index 524b1ef4fd2c787d8fbdeb5b914d17a792037098..870f2d5c432fd49a52ff22bb8085848908f02fff 100644 (file)
@@ -120,10 +120,12 @@ define KernelPackage/sound-mt7620
   KCONFIG:= \
        CONFIG_SND_RALINK_SOC_I2S \
        CONFIG_SND_SIMPLE_CARD \
+       CONFIG_SND_SIMPLE_CARD_UTILS \
        CONFIG_SND_SOC_WM8960
   FILES:= \
        $(LINUX_DIR)/sound/soc/ralink/snd-soc-ralink-i2s.ko \
        $(LINUX_DIR)/sound/soc/generic/snd-soc-simple-card.ko \
+       $(LINUX_DIR)/sound/soc/generic/snd-soc-simple-card-utils.ko \
        $(LINUX_DIR)/sound/soc/codecs/snd-soc-wm8960.ko
   AUTOLOAD:=$(call AutoLoad,90,snd-soc-wm8960 snd-soc-ralink-i2s snd-soc-simple-card)
   $(call AddDepends/sound)