at91: create sdcard image for sama5
authorSandeep Sheriker Mallikarjun <sandeepsheriker.mallikarjun@microchip.com>
Tue, 12 Dec 2017 22:08:26 +0000 (15:08 -0700)
committerJohn Crispin <john@phrozen.org>
Fri, 15 Dec 2017 23:02:14 +0000 (00:02 +0100)
create sdcard image using gen_at91_sdcard_img.sh for sama5 platform
and sdcard image partition layout is:
  P0: Boot (fat32) - contains(at91bootstrap,u-boot,zImage & dtb)
  p1: Rootfs (ext4)

Signed-off-by: Sandeep Sheriker Mallikarjun <sandeepsheriker.mallikarjun@microchip.com>
target/linux/at91/image/gen_at91_sdcard_img.sh [new file with mode: 0755]
target/linux/at91/image/sama5.mk

diff --git a/target/linux/at91/image/gen_at91_sdcard_img.sh b/target/linux/at91/image/gen_at91_sdcard_img.sh
new file mode 100755 (executable)
index 0000000..316ecea
--- /dev/null
@@ -0,0 +1,33 @@
+#!/usr/bin/env bash
+
+#
+# Copyright (C) 2017 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+set -x
+[ $# -eq 5 ] || {
+    echo "SYNTAX: $0 <file> <bootfs image> <rootfs image> <bootfs size> <rootfs size>"
+    exit 1
+}
+
+OUTPUT="$1"
+BOOTFS="$2"
+ROOTFS="$3"
+BOOTFSSIZE="$4"
+ROOTFSSIZE="$5"
+
+head=4
+sect=2048
+
+set `ptgen -o $OUTPUT -h $head -s $sect -l 1024 -t c -p ${BOOTFSSIZE}M -t 83 -p ${ROOTFSSIZE}M`
+
+BOOTOFFSET="$(($1 / 512))"
+BOOTSIZE="$(($2 / 512))"
+ROOTFSOFFSET="$(($3 / 512))"
+ROOTFSSIZE="$(($4 / 512))"
+
+dd bs=512 if="$BOOTFS" of="$OUTPUT" seek="$BOOTOFFSET" conv=notrunc
+dd bs=512 if="$ROOTFS" of="$OUTPUT" seek="$ROOTFSOFFSET" conv=notrunc
index b26715b8ae8a1bdb3c316e7ac93943fe374334e3..d33a3986511e12c765eb2c00d94861aeb0dc4e5f 100644 (file)
@@ -1,3 +1,46 @@
+AT91_SD_BOOT_PARTSIZE:=64
+FAT32_BLOCK_SIZE:=1024
+FAT32_BLOCKS:=$(shell echo \
+  $$(($(AT91_SD_BOOT_PARTSIZE)*1024*1024/$(FAT32_BLOCK_SIZE))))
+
+define Build/at91-sdcard
+  rm -f $@.boot
+  mkfs.fat -C $@.boot $(FAT32_BLOCKS)
+
+  mcopy -i $@.boot $(KDIR)/zImage ::zImage
+
+  $(foreach dts,$(DEVICE_DTS), \
+     mcopy -i $@.boot $(DTS_DIR)/$(dts).dtb \
+        ::$(dts).dtb; \
+     mcopy -i $@.boot \
+        $(BIN_DIR)/u-boot-$(dts:at91-%=%)_mmc/u-boot.bin \
+            ::u-boot.bin; \
+     $(CP) $(BIN_DIR)/at91bootstrap-$(dts:at91-%=%)sd_uboot*/*.bin \
+         $(BIN_DIR)/BOOT.bin; \
+     mcopy -i $@.boot $(BIN_DIR)/BOOT.bin ::BOOT.bin;)
+
+  ./gen_at91_sdcard_img.sh \
+      $(dir $@)$(IMG_PREFIX)-$(PROFILE_SANITIZED)-sdcard.img \
+      $@.boot \
+      $(KDIR)/root.ext4 \
+      $(AT91_SD_BOOT_PARTSIZE) \
+      $(CONFIG_TARGET_ROOTFS_PARTSIZE)
+
+  gzip -nc9 $(dir $@)$(IMG_PREFIX)-$(PROFILE_SANITIZED)-sdcard.img \
+         > $(dir $@)$(IMG_PREFIX)-$(PROFILE_SANITIZED)-sdcard.img.gz
+
+  $(CP) $(dir $@)$(IMG_PREFIX)-$(PROFILE_SANITIZED)-sdcard.img.gz \
+        $(BIN_DIR)/
+
+  rm -f $(BIN_DIR)/BOOT.bin
+  rm -f $@.boot
+endef
+
+define Device/evaluation-sdimage
+  IMAGES += sdcard.img.gz
+  IMAGE/sdcard.img.gz := at91-sdcard
+endef
+
 define Device/default-nand
   BLOCKSIZE := 128k
   PAGESIZE := 2048
@@ -9,6 +52,7 @@ define Device/at91-sama5d3_xplained
   $(Device/evaluation-dtb)
   DEVICE_TITLE := Microchip(Atmel AT91) SAMA5D3 Xplained
   KERNEL_SIZE := 6144k
+  $(Device/evaluation-sdimage)
 endef
 TARGET_DEVICES += at91-sama5d3_xplained
 
@@ -16,6 +60,7 @@ define Device/at91-sama5d2_xplained
   $(Device/evaluation-dtb)
   DEVICE_TITLE := Microchip(Atmel AT91) SAMA5D2 Xplained
   KERNEL_SIZE := 6144k
+  $(Device/evaluation-sdimage)
 endef
 TARGET_DEVICES += at91-sama5d2_xplained
 
@@ -27,6 +72,7 @@ define Device/at91-sama5d4_xplained
   PAGESIZE := 4096
   SUBPAGESIZE := 2048
   MKUBIFS_OPTS := -m $$(PAGESIZE) -e 248KiB -c 2082 -x lzo
+  $(Device/evaluation-sdimage)
 endef
 TARGET_DEVICES += at91-sama5d4_xplained