ar71xx: add ath10k driver and firmware for Netgear R6100 to firmware image
authorStijn Segers <francesco.borromini@inventati.org>
Fri, 10 Mar 2017 17:58:26 +0000 (18:58 +0100)
committerJohn Crispin <john@phrozen.org>
Sat, 11 Mar 2017 07:30:56 +0000 (08:30 +0100)
A Netgear R6100 owner reported the LEDE images lack the ath10k driver and firmware [1]. This patch adds both to the R6100 image.

[1] https://forum.lede-project.org/t/netgear-r6100-5ghz-wifi-not-working-after-initial-install/2222

Signed-off-by: Stijn Segers <francesco.borromini@inventati.org>
target/linux/ar71xx/image/nand.mk

index 292966288634855b9ea925043b2b570cacf55dd4..15e08091207ccef468ca6fdb7ff09753dd1569b1 100644 (file)
@@ -68,7 +68,7 @@ TARGET_DEVICES += z1
 
 define LegacyDevice/R6100
   DEVICE_TITLE := NETGEAR R6100
-  DEVICE_PACKAGES := kmod-usb-core kmod-usb-ohci kmod-usb2 kmod-usb-ledtrig-usbport
+  DEVICE_PACKAGES := kmod-ath10k ath10k-firmware-qca988x kmod-usb-core kmod-usb-ohci kmod-usb2 kmod-usb-ledtrig-usbport
 endef
 LEGACY_DEVICES += R6100