kirkwood: drop support for orphaned boards
authorMathias Kresin <dev@kresin.me>
Wed, 27 Dec 2017 23:40:49 +0000 (00:40 +0100)
committerMathias Kresin <dev@kresin.me>
Tue, 9 Jan 2018 21:06:54 +0000 (22:06 +0100)
No image build code for the Guruplug, Sheevaplug and NSA310S exists. Drop
support for the boards for now.

Signed-off-by: Mathias Kresin <dev@kresin.me>
package/boot/uboot-envtools/files/kirkwood
package/boot/uboot-kirkwood/Makefile
package/boot/uboot-kirkwood/patches/200-openwrt-config.patch
target/linux/kirkwood/base-files/etc/board.d/01_leds
target/linux/kirkwood/base-files/etc/board.d/02_network
target/linux/kirkwood/base-files/lib/kirkwood.sh
target/linux/kirkwood/patches-4.9/107-03-nsa310s.patch [deleted file]
target/linux/kirkwood/patches-4.9/108-on100.patch

index 3b770c12f44d7e01942c8c319e1c83d6cf3a27a2..cfd3550ea98883817ddfc5d91d12b4b7f93ba21c 100644 (file)
@@ -14,14 +14,11 @@ board=$(board_name)
 
 case "$board" in
 dockstar|\
-guruplug-server-plus|\
 ib62x0|\
 linksys-viper|\
 nsa310b|\
 nsa325|\
-pogo_e02|\
-sheevaplug|\
-sheevaplug-esata)
+pogo_e02)
        ubootenv_add_uci_config "/dev/mtd1" "0x0" "0x20000" "0x20000"
        ;;
 linksys-audi)
index 929fca6aeb870bc494a1dd6d81c6af1b08d5e528..94cc30bc06bb4e83631b7261f522f002b819c781 100644 (file)
@@ -64,10 +64,6 @@ define U-Boot/pogo_e02_second_stage
   NAME:=Cloud Engines Pogoplug E02 (second stage)
 endef
 
-define U-Boot/sheevaplug
-  NAME:=SheevaPlug
-endef
-
 UBOOT_TARGETS := \
        dockstar dockstar_second_stage \
        goflexhome \
@@ -75,8 +71,7 @@ UBOOT_TARGETS := \
        iconnect iconnect_second_stage \
        nsa310 \
        nsa325 \
-       pogo_e02 pogo_e02_second_stage \
-       sheevaplug
+       pogo_e02 pogo_e02_second_stage
 
 define Build/Configure
        $(if $(findstring _second_stage,$(BUILD_VARIANT)),
index d6246dc9344ffe0291c6afc374ac29b12aa929d3..04614f77cc0d29a94e0adab423f6b2f24ecf1f8f 100644 (file)
 +#include "openwrt-kirkwood-common.h"
 +
  #endif /* _CONFIG_POGO_E02_H */
---- a/include/configs/sheevaplug.h
-+++ b/include/configs/sheevaplug.h
-@@ -96,4 +96,6 @@
- #define CONFIG_SYS_ATA_IDE1_OFFSET    MV_SATA_PORT1_OFFSET
- #endif /* CONFIG_IDE */
-+#include "openwrt-kirkwood-common.h"
-+
- #endif /* _CONFIG_SHEEVAPLUG_H */
 --- a/include/configs/goflexhome.h
 +++ b/include/configs/goflexhome.h
 @@ -105,4 +105,6 @@
 +CONFIG_FIT_VERBOSE=y
 +CONFIG_LZMA=y
 +CONFIG_LZO=y
---- a/configs/sheevaplug_defconfig
-+++ b/configs/sheevaplug_defconfig
-@@ -28,5 +28,8 @@ CONFIG_SYS_NS16550=y
- CONFIG_USB=y
- CONFIG_USB_EHCI_HCD=y
- CONFIG_USB_STORAGE=y
--CONFIG_LZMA=y
- CONFIG_OF_LIBFDT=y
-+CONFIG_FIT=y
-+CONFIG_FIT_VERBOSE=y
-+CONFIG_LZMA=y
-+CONFIG_LZO=y
index 0d897591808e6314c6df12866fb8d0e8d01c9d68..a0b4eca04fce6e52d8cc601cd5ccfe79d2b3784a 100755 (executable)
@@ -34,9 +34,6 @@ case "$board" in
        ucidef_set_led_default "health" "health" "pogo_e02:green:health" "1"
        ucidef_set_led_default "fault" "fault" "pogo_e02:orange:fault" "1"
        ;;
-"guruplug-server-plus")
-       ucidef_set_led_timer "health" "health" "guruplug:red:health" "200" "800"
-       ;;
 "nsa310b")
        ucidef_set_led_default "health" "health" "nsa310:green:sys" "1"
        ucidef_set_led_usbhost "usb" "USB" "nsa310:green:usb"
@@ -49,10 +46,6 @@ case "$board" in
        ucidef_set_led_ataport "hdd1" "HDD1" "nsa325:green:sata1" "1"
        ucidef_set_led_ataport "hdd2" "HDD2" "nsa325:green:sata2" "2"
        ;;
-"sheevaplug" | \
-"sheevaplug-esata")
-       ucidef_set_led_timer "health" "health" "sheevaplug:blue:health" "200" "800"
-       ;;
 *)
        ;;
 esac
index 85049d296880fa05d8b8b3bb5ae8f7f1ff87c720..549d232df936bae899df32e2c3109ea9e11a4de8 100755 (executable)
@@ -16,15 +16,9 @@ case "$board" in
 "goflexnet"|\
 "ib62x0"|\
 "iconnect"|\
-"nsa310s"|\
-"pogo_e02"|\
-"sheevaplug"|\
-"sheevaplug-esata")
+"pogo_e02")
        ucidef_set_interface_lan "eth0" "dhcp"
        ;;
-"guruplug-server-plus")
-       ucidef_set_interface_lan "eth0 eth1" "dhcp"
-       ;;
 "linksys-audi"|\
 "linksys-viper")
        ucidef_add_switch "switch0" \
index f1229fa97bd419424eb57d04846c18c2b0e122af..6474b061766f76c5c03ef96c42d2a7a66219064e 100755 (executable)
@@ -49,26 +49,10 @@ kirkwood_board_detect() {
                name="linksys-viper"
                ;;
 
-       "Globalscale Technologies Guruplug Server Plus")
-               name="guruplug-server-plus"
-               ;;
-
-       "Globalscale Technologies SheevaPlug")
-               name="sheevaplug"
-               ;;
-
-       "Globalscale Technologies eSATA SheevaPlug")
-               name="sheevaplug-esata"
-               ;;
-
        "ZyXEL NSA310b")
                name="nsa310b"
                ;;
 
-       "ZyXEL NSA310S")
-               name="nsa310s"
-               ;;
-
        "ZyXEL NSA325")
                name="nsa325"
                ;;
diff --git a/target/linux/kirkwood/patches-4.9/107-03-nsa310s.patch b/target/linux/kirkwood/patches-4.9/107-03-nsa310s.patch
deleted file mode 100644 (file)
index 0e69f0c..0000000
+++ /dev/null
@@ -1,267 +0,0 @@
---- a/arch/arm/boot/dts/Makefile
-+++ b/arch/arm/boot/dts/Makefile
-@@ -239,6 +239,7 @@ dtb-$(CONFIG_MACH_KIRKWOOD) += \
-       kirkwood-nsa310.dtb \
-       kirkwood-nsa310a.dtb \
-       kirkwood-nsa310b.dtb \
-+      kirkwood-nsa310s.dtb \
-       kirkwood-nsa320.dtb \
-       kirkwood-nsa325.dtb \
-       kirkwood-openblocks_a6.dtb \
---- /dev/null
-+++ b/arch/arm/boot/dts/kirkwood-nsa310s.dts
-@@ -0,0 +1,254 @@
-+/dts-v1/;
-+
-+#include "kirkwood-nsa3x0-common.dtsi"
-+
-+/ {
-+      model = "ZyXEL NSA310S";
-+      compatible = "zyxel,nsa320s", "marvell,kirkwood-88f6702", "marvell,kirkwood";
-+
-+      memory {
-+              device_type = "memory";
-+              reg = <0x00000000 0x10000000>;
-+      };
-+
-+      chosen {
-+              bootargs = "console=ttyS0,115200n8 earlyprintk";
-+              stdout-path = &uart0;
-+      };
-+
-+      ocp@f1000000 {
-+              pinctrl: pin-controller@10000 {
-+                      pinctrl-names = "default";
-+
-+                      pmx_sata0: pmx-sata0 {
-+                              marvell,pins;
-+                              marvell,function = "sata0";
-+                      };
-+
-+                      pmx_sata1: pmx-sata1 {
-+                              marvell,pins;
-+                              marvell,function = "sata1";
-+                      };
-+
-+                      pmx_usb_power: pmx-usb-power {
-+                              marvell,pins = "mpp21";
-+                              marvell,function = "gpio";
-+                      };
-+
-+                      pmx_pwr_off: pmx-pwr-off {
-+                              marvell,pins = "mpp27";
-+                              marvell,function = "gpio";
-+                      };
-+
-+                      pmx_btn_reset: pmx-btn-reset {
-+                              marvell,pins = "mpp24";
-+                              marvell,function = "gpio";
-+                      };
-+
-+                      pmx_btn_copy: pmx-btn-copy {
-+                              marvell,pins = "mpp25";
-+                              marvell,function = "gpio";
-+                      };
-+
-+                      pmx_btn_power: pmx-btn-power {
-+                              marvell,pins = "mpp26";
-+                              marvell,function = "gpio";
-+                      };
-+
-+                      pmx_led_hdd2_green: pmx-led-hdd2-green {
-+                              marvell,pins = "mpp34";
-+                              marvell,function = "gpio";
-+                      };
-+
-+                      pmx_led_hdd2_red: pmx-led-hdd2-red {
-+                              marvell,pins = "mpp12";
-+                              marvell,function = "gpio";
-+                      };
-+
-+                      pmx_led_usb_green: pmx-led-usb-green {
-+                              marvell,pins = "mpp15";
-+                              marvell,function = "gpio";
-+                      };
-+
-+                      pmx_led_copy_green: pmx-led-copy-green {
-+                              marvell,pins = "mpp22";
-+                              marvell,function = "gpio";
-+                      };
-+
-+                      pmx_led_copy_red: pmx-led-copy-red {
-+                              marvell,pins = "mpp23";
-+                              marvell,function = "gpio";
-+                      };
-+
-+                      pmx_led_sys_green: pmx-led-sys-green {
-+                              marvell,pins = "mpp28";
-+                              marvell,function = "gpio";
-+                      };
-+
-+                      pmx_led_sys_orange: pmx-led-sys-orange {
-+                              marvell,pins = "mpp29";
-+                              marvell,function = "gpio";
-+                      };
-+
-+                      pmx_led_hdd1_green: pmx-led-hdd1-green {
-+                              marvell,pins = "mpp16";
-+                              marvell,function = "gpio";
-+                      };
-+
-+                      pmx_led_hdd1_red: pmx-led-hdd1-red {
-+                              marvell,pins = "mpp13";
-+                              marvell,function = "gpio";
-+                      };
-+
-+                      pmx_pwr_sata1: pmx-pwr-sata1 {
-+                              marvell,pins = "mpp33";
-+                              marvell,function = "gpio";
-+                      };
-+
-+              };
-+
-+              i2c@11000 {
-+                      status = "okay";
-+
-+                      ht1382: rtc@68 {
-+                              compatible = "htk,ht1382";
-+                              reg = <0x68>;
-+                      };
-+              };
-+      };
-+
-+      regulators {
-+              compatible = "simple-bus";
-+              #address-cells = <1>;
-+              #size-cells = <0>;
-+              pinctrl-0 = <&pmx_pwr_sata1>;
-+              pinctrl-names = "default";
-+
-+              usb0_power: regulator@1 {
-+                      enable-active-high;
-+              };
-+
-+              sata1_power: regulator@2 {
-+                      compatible = "regulator-fixed";
-+                      reg = <2>;
-+                      regulator-name = "SATA1 Power";
-+                      regulator-min-microvolt = <5000000>;
-+                      regulator-max-microvolt = <5000000>;
-+                      regulator-always-on;
-+                      regulator-boot-on;
-+                      enable-active-high;
-+                      gpio = <&gpio1 1 GPIO_ACTIVE_HIGH>;
-+              };
-+      };
-+
-+      gpio_keys {
-+              power {
-+                      gpios = <&gpio0 26 GPIO_ACTIVE_HIGH>;
-+              };
-+              copy {
-+                      gpios = <&gpio0 25 GPIO_ACTIVE_LOW>;
-+              };
-+              reset {
-+                      gpios = <&gpio0 24 GPIO_ACTIVE_LOW>;
-+              };
-+      };
-+
-+      gpio-leds {
-+              compatible = "gpio-leds";
-+
-+              green-sys {
-+                      label = "nsa310s:green:sys";
-+                      gpios = <&gpio0 28 GPIO_ACTIVE_HIGH>;
-+              };
-+              orange-sys {
-+                      label = "nsa310s:orange:sys";
-+                      gpios = <&gpio0 29 GPIO_ACTIVE_HIGH>;
-+              };
-+              green-hdd1 {
-+                      label = "nsa310s:green:hdd1";
-+                      gpios = <&gpio0 16 GPIO_ACTIVE_HIGH>;
-+              };
-+              red-hdd1 {
-+                      label = "nsa310s:red:hdd1";
-+                      gpios = <&gpio0 13 GPIO_ACTIVE_HIGH>;
-+              };
-+              green-hdd2 {
-+                      label = "nsa310s:green:hdd2";
-+                      gpios = <&gpio1 2 GPIO_ACTIVE_HIGH>;
-+              };
-+              red-hdd2 {
-+                      label = "nsa310s:red:hdd2";
-+                      gpios = <&gpio0 12 GPIO_ACTIVE_HIGH>;
-+              };
-+              green-usb {
-+                      label = "nsa310s:green:usb";
-+                      gpios = <&gpio0 15 GPIO_ACTIVE_HIGH>;
-+              };
-+              green-copy {
-+                      label = "nsa310s:green:copy";
-+                      gpios = <&gpio0 22 GPIO_ACTIVE_HIGH>;
-+              };
-+              red-copy {
-+                      label = "nsa310s:red:copy";
-+                      gpios = <&gpio0 23 GPIO_ACTIVE_HIGH>;
-+              };
-+      };
-+
-+      gpio_poweroff {
-+              gpios = <&gpio0 27 GPIO_ACTIVE_HIGH>;
-+      };
-+};
-+
-+&nand {
-+      status = "okay";
-+      chip-delay = <35>;
-+
-+      partition@0 {
-+              label = "uboot";
-+              reg = <0x0000000 0xe0000>;
-+              read-only;
-+      };
-+
-+      partition@e0000 {
-+              label = "uboot_env";
-+              reg = <0xe0000 0x100000>;
-+      };
-+
-+      partition@100000 {
-+              label = "second stage u-boot";
-+              reg = <0x100000 0x200000>;
-+      };
-+
-+      partition@200000 {
-+              label = "ubi";
-+              reg = <0x200000 0x7e00000>;
-+      };
-+};
-+
-+&sata {
-+      status = "okay";
-+      nr-ports = <2>;
-+};
-+
-+&mdio {
-+      status = "okay";
-+      ethphy0: ethernet-phy@1 {
-+              compatible = "marvell,88e1318s";
-+              reg = <1>;
-+              marvell,reg-init = <0x1 0x16 0x0 0x3>,
-+                                                      <0x1 0x10 0x0 0x1017>,
-+                                                      <0x1 0x11 0x0 0x4408>,
-+                                                      <0x1 0x16 0x0 0x0>,
-+                                                      <0x1 0x4 0x0 0x1e1>,
-+                                                      <0x1 0x9 0x0 0x300>,
-+                                                      <0x1 0x10 0x0 0x3860>,
-+                                                      <0x1 0x0 0x0 0x9140>;
-+      };
-+};
-+
-+&eth0 {
-+      status = "okay";
-+      ethernet0-port@0 {
-+              phy-handle = <&ethphy0>;
-+      };
-+};
index 28c3e535d266b40ea7ab9e4c24db6756003aeba3..3cab70aaa84f709630b86fe975fdbec48d1013a0 100644 (file)
 +};
 --- a/arch/arm/boot/dts/Makefile
 +++ b/arch/arm/boot/dts/Makefile
-@@ -242,6 +242,7 @@ dtb-$(CONFIG_MACH_KIRKWOOD) += \
-       kirkwood-nsa310s.dtb \
+@@ -241,6 +241,7 @@ dtb-$(CONFIG_MACH_KIRKWOOD) += \
+       kirkwood-nsa310b.dtb \
        kirkwood-nsa320.dtb \
        kirkwood-nsa325.dtb \
 +      kirkwood-on100.dtb \