ramips: add U-Boot env support for ALFA Network AC1200RM
authorPiotr Dymacz <pepe2k@gmail.com>
Mon, 26 Feb 2018 22:00:07 +0000 (23:00 +0100)
committerPiotr Dymacz <pepe2k@gmail.com>
Fri, 6 Apr 2018 21:11:00 +0000 (23:11 +0200)
Signed-off-by: Piotr Dymacz <pepe2k@gmail.com>
package/boot/uboot-envtools/files/ramips
target/linux/ramips/dts/AC1200RM.dts
target/linux/ramips/image/mt7620.mk

index 88f561b0f4ab7a7906831acf3b29b58f4a5b73e1..f992f41bc89fde2759e0ffc1cf0db3af6c45d86b 100644 (file)
@@ -13,6 +13,7 @@ touch /etc/config/ubootenv
 board=$(board_name)
 
 case "$board" in
+alfa-network,ac1200rm|\
 alfa-network,awusfree1)
        ubootenv_add_uci_config "/dev/mtd1" "0x0" "0x1000" "0x1000"
        ;;
index 9305cb00e061add14c8179009636746f48cb0f6c..9bdbf5cadf84f1818ffd72fcebb3332a76e5a8cb 100644 (file)
                };
 
                partition@30000 {
+                       label = "u-boot-env";
+                       reg = <0x30000 0x1000>;
+               };
+
+               partition@031000 {
                        label = "config";
-                       reg = <0x30000 0x10000>;
+                       reg = <0x31000 0xf000>;
                        read-only;
                };
 
index e0a47b7340708080cf0317650fefaefa8e2fd4fe..c12a9152456b1ddb29586e7c302a30413e193e7f 100644 (file)
@@ -32,7 +32,7 @@ define Device/alfa-network_ac1200rm
   DTS := AC1200RM
   IMAGE_SIZE := 16064k
   DEVICE_TITLE := ALFA Network AC1200RM
-  DEVICE_PACKAGES := kmod-usb2 kmod-usb-ohci
+  DEVICE_PACKAGES := kmod-usb2 kmod-usb-ohci uboot-envtools
 endef
 TARGET_DEVICES += alfa-network_ac1200rm