ramips: fix AR670W partition alignment
authorClaudio Leite <leitec@gmail.com>
Sun, 5 Feb 2017 08:59:45 +0000 (03:59 -0500)
committerJohn Crispin <john@phrozen.org>
Thu, 9 Feb 2017 08:14:45 +0000 (09:14 +0100)
mtdsplit_lzma requires that the rootfs be aligned to a block boundary.
Pad the kernel partition to make this so.

Signed-off-by: Claudio Leite <leitec@gmail.com>
target/linux/ramips/image/rt288x.mk

index 4a0d6d4ae7c9ec6e91fe4cdd220f37d9b70badc1..86a506388c5de26257098327938b30ddfb64539b 100644 (file)
@@ -14,7 +14,7 @@ define Device/ar670w
   BLOCKSIZE := 64k
   DEVICE_TITLE := Airlink AR670W
   IMAGE_SIZE := $(ralink_default_fw_size_4M)
-  KERNEL := $(KERNEL_DTB)
+  KERNEL := $(KERNEL_DTB) | pad-to $$(BLOCKSIZE)
   IMAGES += factory.bin
   IMAGE/factory.bin := $$(sysupgrade_bin) | check-size $$$$(IMAGE_SIZE) | \
        wrg-header wrgn16a_airlink_ar670w