uboot-kirkwood: fix default u-boot selection
authorMathias Kresin <dev@kresin.me>
Thu, 28 Dec 2017 00:15:57 +0000 (01:15 +0100)
committerMathias Kresin <dev@kresin.me>
Tue, 9 Jan 2018 21:06:55 +0000 (22:06 +0100)
Build the Seagate GoFlexHome u-boot for the Seagate GoFlexNet as well. The
name clearly indicates that the u-boot can be used for both boards

Build the Zyxel NSA310 u-boot if the NSA310B image is selected.

Signed-off-by: Mathias Kresin <dev@kresin.me>
package/boot/uboot-kirkwood/Makefile

index 94cc30bc06bb4e83631b7261f522f002b819c781..aa143280d31631d9009b7efc14fb4364cb20a3bb 100644 (file)
@@ -30,6 +30,7 @@ endef
 
 define U-Boot/goflexhome
   NAME:=the Seagate GoFlexHome/GoFlexNet
+  BUILD_DEVICES+=goflexnet
 endef
 
 define U-Boot/ib62x0
@@ -50,6 +51,7 @@ endef
 
 define U-Boot/nsa310
   NAME:=Zyxel NSA310
+  BUILD_DEVICES:=nsa310b
 endef
 
 define U-Boot/nsa325