kernel: update kernel 4.4 to 4.4.53
authorHauke Mehrtens <hauke@hauke-m.de>
Sun, 12 Mar 2017 12:05:26 +0000 (13:05 +0100)
committerHauke Mehrtens <hauke@hauke-m.de>
Sun, 12 Mar 2017 14:46:02 +0000 (15:46 +0100)
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
include/kernel-version.mk
target/linux/apm821xx/patches-4.4/040-backport_leds-convert-IDE-trigger-to-common-disk-trigger.patch
target/linux/ar71xx/patches-4.4/910-unaligned_access_hacks.patch
target/linux/brcm47xx/patches-4.4/030-MIPS-BCM47XX-Add-Luxul-devices-to-the-database.patch
target/linux/brcm47xx/patches-4.4/130-MIPS-bcm47xx-Fix-button-inversion-for-Asus-WL-500W.patch [deleted file]
target/linux/brcm47xx/patches-4.4/901-Revert-bcma-switch-GPIO-portions-to-use-GPIOLIB_IRQC.patch
target/linux/generic/patches-4.4/020-bcma-from-4.5.patch
target/linux/generic/patches-4.4/025-bcma-from-4.11.patch
target/linux/generic/patches-4.4/062-02-MIPS-Stack-unwinding-while-on-IRQ-stack.patch
target/linux/ixp4xx/patches-4.4/295-latch_led_driver.patch
target/linux/lantiq/patches-4.4/0070-MIPS-Lantiq-Keep-ethernet-enabled-during-boot.patch [deleted file]

index de140ea767c182ac19ada79e021c06f6ffc9f1af..7fecc3bf4bf50ed891b7070f402caf2f97318a13 100644 (file)
@@ -3,11 +3,11 @@
 LINUX_RELEASE?=1
 
 LINUX_VERSION-3.18 = .43
-LINUX_VERSION-4.4 = .52
+LINUX_VERSION-4.4 = .53
 LINUX_VERSION-4.9 = .14
 
 LINUX_KERNEL_HASH-3.18.43 = 1236e8123a6ce537d5029232560966feed054ae31776fe8481dd7d18cdd5492c
-LINUX_KERNEL_HASH-4.4.52 = e8d2ddaece73e1a34e045bbdcdcc1383f658e24537797f8d8e0dd520cf1b1f06
+LINUX_KERNEL_HASH-4.4.53 = 7efecdd5d47c173fc54bbefa5f78e31782532cfa8dbc0df47473e87e35cdf3e6
 LINUX_KERNEL_HASH-4.9.14 = 534d343f4ca5c55d7214694a2a378897e8ee2adf576563f069da010093b3b640
 
 ifdef KERNEL_PATCHVER
index 4e0be8d5adb4b395521ef63a46e3725c1c8a58a1..48714aa466233576c7a1f719e127c012c45c0ec6 100644 (file)
@@ -193,7 +193,7 @@ Signed-off-by: Jacek Anaszewski <j.anaszewski@samsung.com>
 -MODULE_LICENSE("GPL");
 --- a/include/linux/leds.h
 +++ b/include/linux/leds.h
-@@ -302,10 +302,10 @@ static inline void *led_get_trigger_data
+@@ -308,10 +308,10 @@ static inline void *led_get_trigger_data
  #endif /* CONFIG_LEDS_TRIGGERS */
  
  /* Trigger specific functions */
index 1e68cf72f56eabcba703b027675e53b9776c8d89..9e6a039316c8c3557d50b433c20632fe66b9174c 100644 (file)
@@ -42,7 +42,7 @@
        } while (word != stop);
  
        return csum_fold(csum);
-@@ -212,73 +216,6 @@ static inline __sum16 ip_compute_csum(co
+@@ -214,73 +218,6 @@ static inline __sum16 ip_compute_csum(co
        return csum_fold(csum_partial(buff, len, 0));
  }
  
index 402d9360f4078d78a1a8abba7ba3c113c0f3f7b2..49ba62373355aa9aa5e1580ed659e365cd60a02f 100644 (file)
@@ -43,7 +43,7 @@ Signed-off-by: Ralf Baechle <ralf@linux-mips.org>
        {{BCM47XX_BOARD_NETGEAR_WGR614V9, "Netgear WGR614 V9"}, "U12H094T00_NETGEAR"},
 --- a/arch/mips/bcm47xx/buttons.c
 +++ b/arch/mips/bcm47xx/buttons.c
-@@ -302,6 +302,51 @@ bcm47xx_buttons_linksys_wrtsl54gs[] __in
+@@ -308,6 +308,51 @@ bcm47xx_buttons_linksys_wrtsl54gs[] __in
  /* Luxul */
  
  static const struct gpio_keys_button
@@ -95,7 +95,7 @@ Signed-off-by: Ralf Baechle <ralf@linux-mips.org>
  bcm47xx_buttons_luxul_xwr_1750_v1[] = {
        BCM47XX_GPIO_KEY(14, BTN_TASK),
  };
-@@ -561,6 +606,33 @@ int __init bcm47xx_buttons_register(void
+@@ -567,6 +612,33 @@ int __init bcm47xx_buttons_register(void
                err = bcm47xx_copy_bdata(bcm47xx_buttons_linksys_wrtsl54gs);
                break;
  
diff --git a/target/linux/brcm47xx/patches-4.4/130-MIPS-bcm47xx-Fix-button-inversion-for-Asus-WL-500W.patch b/target/linux/brcm47xx/patches-4.4/130-MIPS-bcm47xx-Fix-button-inversion-for-Asus-WL-500W.patch
deleted file mode 100644 (file)
index 7d671cf..0000000
+++ /dev/null
@@ -1,38 +0,0 @@
-From: Mirko Parthey <mirko.parthey@web.de>
-Subject: [PATCH] MIPS: bcm47xx: Fix button inversion for Asus WL-500W
-
-The Asus WL-500W buttons are active high,
-but the software treats them as active low.
-Fix the inverted logic.
-
-Signed-off-by: Mirko Parthey <mirko.parthey@web.de>
----
- arch/mips/bcm47xx/buttons.c | 10 ++++++++--
- 1 file changed, 8 insertions(+), 2 deletions(-)
-
---- a/arch/mips/bcm47xx/buttons.c
-+++ b/arch/mips/bcm47xx/buttons.c
-@@ -17,6 +17,12 @@
-               .active_low     = 1,                                    \
-       }
-+#define BCM47XX_GPIO_KEY_H(_gpio, _code)                              \
-+      {                                                               \
-+              .code           = _code,                                \
-+              .gpio           = _gpio,                                \
-+      }
-+
- /* Asus */
- static const struct gpio_keys_button
-@@ -79,8 +85,8 @@ bcm47xx_buttons_asus_wl500gpv2[] __initc
- static const struct gpio_keys_button
- bcm47xx_buttons_asus_wl500w[] __initconst = {
--      BCM47XX_GPIO_KEY(6, KEY_RESTART),
--      BCM47XX_GPIO_KEY(7, KEY_WPS_BUTTON),
-+      BCM47XX_GPIO_KEY_H(6, KEY_RESTART),
-+      BCM47XX_GPIO_KEY_H(7, KEY_WPS_BUTTON),
- };
- static const struct gpio_keys_button
index 4968c1bbac4a8570ae0843143a401524942b771a..57799ee08280af48b190960e9ef16925c6eadcab 100644 (file)
@@ -193,9 +193,9 @@ Signed-off-by: Rafał Miłecki <zajec5@gmail.com>
 +      chip->to_irq            = bcma_gpio_to_irq;
 +#endif
  #if IS_BUILTIN(CONFIG_OF)
-       if (cc->core->bus->hosttype == BCMA_HOSTTYPE_SOC)
-               chip->of_node   = cc->core->dev.of_node;
-@@ -217,13 +249,13 @@ int bcma_gpio_init(struct bcma_drv_cc *c
+       chip->of_node           = cc->core->dev.of_node;
+ #endif
+@@ -216,13 +248,13 @@ int bcma_gpio_init(struct bcma_drv_cc *c
        else
                chip->base              = -1;
  
@@ -212,7 +212,7 @@ Signed-off-by: Rafał Miłecki <zajec5@gmail.com>
                return err;
        }
  
-@@ -232,7 +264,7 @@ int bcma_gpio_init(struct bcma_drv_cc *c
+@@ -231,7 +263,7 @@ int bcma_gpio_init(struct bcma_drv_cc *c
  
  int bcma_gpio_unregister(struct bcma_drv_cc *cc)
  {
index 21ebff58b68f79afe671db7c1bb70261e5393209..c5d7bc7e5e920ef88d287e0e520616699e5b162e 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/bcma/main.c
 +++ b/drivers/bcma/main.c
-@@ -668,11 +668,36 @@ static int bcma_device_uevent(struct dev
+@@ -672,11 +672,36 @@ static int bcma_device_uevent(struct dev
                              core->id.rev, core->id.class);
  }
  
@@ -38,7 +38,7 @@
        if (err)
                return err;
  
-@@ -691,7 +716,7 @@ static int __init bcma_modinit(void)
+@@ -695,7 +720,7 @@ static int __init bcma_modinit(void)
  
        return err;
  }
index d5bdd2d5aedbf0ca24cd2ec2a6160ab1994f7887..a3b0321986dc359cb8e2cee6c70b0e36e1d36d90 100644 (file)
                } else {
                        core->dev.dma_mask = &core->dev.coherent_dma_mask;
                        core->dma_dev = &core->dev;
-@@ -633,8 +634,11 @@ static int bcma_device_probe(struct devi
-                                              drv);
-       int err = 0;
-+      get_device(dev);
-       if (adrv->probe)
-               err = adrv->probe(core);
-+      if (err)
-+              put_device(dev);
-       return err;
- }
-@@ -647,6 +651,7 @@ static int bcma_device_remove(struct dev
-       if (adrv->remove)
-               adrv->remove(core);
-+      put_device(dev);
-       return 0;
- }
index 513e904e52cde7448ed9815f9a5f8fe447078e93..fc559ee6ddb847cfd2e97929581dad4bdd66a160 100644 (file)
@@ -19,7 +19,7 @@ Signed-off-by: Matt Redfearn <matt.redfearn@imgtec.com>
  #include <asm/msa.h>
  #include <asm/pgtable.h>
  #include <asm/mipsregs.h>
-@@ -507,7 +508,19 @@ EXPORT_SYMBOL(unwind_stack_by_address);
+@@ -552,7 +553,19 @@ EXPORT_SYMBOL(unwind_stack_by_address);
  unsigned long unwind_stack(struct task_struct *task, unsigned long *sp,
                           unsigned long pc, unsigned long *ra)
  {
index a2f846373b07090088526e7dbfead0206f0b2a58..2b475161cfa3e2b92d09ba3cc713f629735480bf 100644 (file)
 +MODULE_DESCRIPTION("Latch LED driver");
 --- a/include/linux/leds.h
 +++ b/include/linux/leds.h
-@@ -376,4 +376,18 @@ static inline void ledtrig_cpu(enum cpu_
+@@ -385,4 +385,18 @@ static inline void ledtrig_cpu(enum cpu_
  }
  #endif
  
diff --git a/target/linux/lantiq/patches-4.4/0070-MIPS-Lantiq-Keep-ethernet-enabled-during-boot.patch b/target/linux/lantiq/patches-4.4/0070-MIPS-Lantiq-Keep-ethernet-enabled-during-boot.patch
deleted file mode 100644 (file)
index 67cf7d3..0000000
+++ /dev/null
@@ -1,53 +0,0 @@
-From: Felix Fietkau <nbd@nbd.name>
-Date: Thu, 19 Jan 2017 14:14:36 +0100
-Subject: [PATCH] MIPS: Lantiq: Keep ethernet enabled during boot
-
-Disabling ethernet during reboot (only to enable it again when the
-ethernet driver attaches) can put the chip into a faulty state where it
-corrupts the header of all incoming packets.
-
-This happens if packets arrive during the time window where the core is
-disabled, and it can be easily reproduced by rebooting while sending a
-flood ping to the broadcast address.
-
-Cc: john@phrozen.org
-Cc: hauke.mehrtens@lantiq.com
-Cc: stable@vger.kernel.org
-Fixes: 95135bfa7ead ("MIPS: Lantiq: Deactivate most of the devices by default")
-Signed-off-by: Felix Fietkau <nbd@nbd.name>
----
-
---- a/arch/mips/lantiq/xway/sysctrl.c
-+++ b/arch/mips/lantiq/xway/sysctrl.c
-@@ -564,7 +564,7 @@ void __init ltq_soc_init(void)
-               clkdev_add_pmu("1a800000.pcie", "msi", 1, 1, PMU1_PCIE2_MSI);
-               clkdev_add_pmu("1a800000.pcie", "pdi", 1, 1, PMU1_PCIE2_PDI);
-               clkdev_add_pmu("1a800000.pcie", "ctl", 1, 1, PMU1_PCIE2_CTL);
--              clkdev_add_pmu("1e108000.eth", NULL, 1, 0, PMU_SWITCH | PMU_PPE_DP);
-+              clkdev_add_pmu("1e108000.eth", NULL, 0, 0, PMU_SWITCH | PMU_PPE_DP);
-               clkdev_add_pmu("1da00000.usif", "NULL", 1, 0, PMU_USIF);
-               clkdev_add_pmu("1e103100.deu", NULL, 1, 0, PMU_DEU);
-       } else if (of_machine_is_compatible("lantiq,ar10")) {
-@@ -572,7 +572,7 @@ void __init ltq_soc_init(void)
-                                 ltq_ar10_fpi_hz(), ltq_ar10_pp32_hz());
-               clkdev_add_pmu("1e101000.usb", "ctl", 1, 0, PMU_USB0);
-               clkdev_add_pmu("1e106000.usb", "ctl", 1, 0, PMU_USB1);
--              clkdev_add_pmu("1e108000.eth", NULL, 1, 0, PMU_SWITCH |
-+              clkdev_add_pmu("1e108000.eth", NULL, 0, 0, PMU_SWITCH |
-                              PMU_PPE_DP | PMU_PPE_TC);
-               clkdev_add_pmu("1da00000.usif", "NULL", 1, 0, PMU_USIF);
-               clkdev_add_pmu("1f203000.rcu", "gphy", 1, 0, PMU_GPHY);
-@@ -594,11 +594,11 @@ void __init ltq_soc_init(void)
-               clkdev_add_pmu(NULL, "ahb", 1, 0, PMU_AHBM | PMU_AHBS);
-               clkdev_add_pmu("1da00000.usif", "NULL", 1, 0, PMU_USIF);
--              clkdev_add_pmu("1e108000.eth", NULL, 1, 0,
-+              clkdev_add_pmu("1e108000.eth", NULL, 0, 0,
-                               PMU_SWITCH | PMU_PPE_DPLUS | PMU_PPE_DPLUM |
-                               PMU_PPE_EMA | PMU_PPE_TC | PMU_PPE_SLL01 |
-                               PMU_PPE_QSB | PMU_PPE_TOP);
--              clkdev_add_pmu("1f203000.rcu", "gphy", 1, 0, PMU_GPHY);
-+              clkdev_add_pmu("1f203000.rcu", "gphy", 0, 0, PMU_GPHY);
-               clkdev_add_pmu("1e103000.sdio", NULL, 1, 0, PMU_SDIO);
-               clkdev_add_pmu("1e103100.deu", NULL, 1, 0, PMU_DEU);
-               clkdev_add_pmu("1e116000.mei", "dfe", 1, 0, PMU_DFE);