mac80211: Re-enable encrypted 11s meshpoint
authorSven Eckelmann <sven.eckelmann@openmesh.com>
Mon, 14 May 2018 13:11:45 +0000 (15:11 +0200)
committerDaniel Golle <daniel@makrotopia.org>
Mon, 14 May 2018 16:37:44 +0000 (18:37 +0200)
The commit 574e4377fad5 ("mac80211: properly setup mesh interface") uses
the variable $wpa to decide whether encrypted meshpoint is requested by the
user or not. But the variable $wpa will only be set correctly after the
function wireless_vif_parse_encryption is called.

Fixes: 574e4377fad5 ("mac80211: properly setup mesh interface")
Signed-off-by: Sven Eckelmann <sven.eckelmann@openmesh.com>
package/kernel/mac80211/Makefile
package/kernel/mac80211/files/lib/netifd/wireless/mac80211.sh

index 499de2fd4edf833152873d0a07d192a99ea0f4fd..2effbf16a5c759ef0727e08e2a10862f399e8f0e 100644 (file)
@@ -11,7 +11,7 @@ include $(INCLUDE_DIR)/kernel.mk
 PKG_NAME:=mac80211
 
 PKG_VERSION:=2017-11-01
-PKG_RELEASE:=6
+PKG_RELEASE:=7
 PKG_SOURCE_URL:=http://mirror2.openwrt.org/sources
 PKG_HASH:=8437ab7886b988c8152e7a4db30b7f41009e49a3b2cb863edd05da1ecd7eb05a
 
index dbe4aac7d78832fdd8005b539be6bb1af0eb915d..70def756b2d5dc0f361a293f12dea5782ff8b6fe 100644 (file)
@@ -634,8 +634,8 @@ mac80211_setup_vif() {
        case "$mode" in
                mesh)
                        json_get_vars key
+                       wireless_vif_parse_encryption
                        if [ "$wpa" -gt 0 -o "$auto_channel" -gt 0 ] || chan_is_dfs "$phy" "$channel"; then
-                               wireless_vif_parse_encryption
                                freq="$(get_freq "$phy" "$channel")"
                                mac80211_setup_supplicant || failed=1
                        else