kernel: fix chipidea module dependencies
authorJohn Crispin <john@phrozen.org>
Fri, 20 Jan 2017 05:38:59 +0000 (06:38 +0100)
committerJohn Crispin <john@phrozen.org>
Fri, 20 Jan 2017 05:43:13 +0000 (06:43 +0100)
Signed-off-by: John Crispin <john@phrozen.org>
package/kernel/linux/modules/usb.mk

index 2e449318ba92c06af859345bbaf6b53246a667f5..6be8a2aa8668845bd2e6b9663edebf7679f1eab0 100644 (file)
@@ -1377,7 +1377,7 @@ $(eval $(call KernelPackage,usbip-server))
 
 define KernelPackage/usb-chipidea
   TITLE:=Host and device support for Chipidea controllers
-  DEPENDS:=+USB_GADGET_SUPPORT:kmod-usb-gadget
+  DEPENDS:=+USB_GADGET_SUPPORT:kmod-usb-gadget @TARGET_ar71xx +kmod-usb2
   KCONFIG:= \
        CONFIG_NOP_USB_XCEIV=y \
        CONFIG_EXTCON \