ltq-atm: remove xrx200 special handling
authorMathias Kresin <dev@kresin.me>
Sun, 15 Oct 2017 10:34:33 +0000 (12:34 +0200)
committerMathias Kresin <dev@kresin.me>
Wed, 25 Oct 2017 06:45:05 +0000 (08:45 +0200)
The lantiq ATM driver is load for all subtargets on demand now. There
is not need to handle the xrx200 ATM driver in a special way any
longer.

Signed-off-by: Mathias Kresin <dev@kresin.me>
package/kernel/lantiq/ltq-atm/Makefile

index 065ce17e34192cae9055da3aa3e419c99e6cb3a6..a4f9c0337ffb6af2375fde4bbbec8c5da20a6280 100644 (file)
@@ -29,11 +29,7 @@ endef
 KernelPackage/ltq-atm-danube=$(call KernelPackage/ltq-atm-template,danube,(TARGET_lantiq_xway||TARGET_lantiq_xway_legacy))
 KernelPackage/ltq-atm-ar9=$(call KernelPackage/ltq-atm-template,ar9,TARGET_lantiq_xway)
 KernelPackage/ltq-atm-ase=$(call KernelPackage/ltq-atm-template,ase,TARGET_lantiq_ase)
-
-define KernelPackage/ltq-atm-vr9
-  $(call KernelPackage/ltq-atm-template,vr9,TARGET_lantiq_xrx200)
-  AUTOLOAD:=
-endef
+KernelPackage/ltq-atm-vr9=$(call KernelPackage/ltq-atm-template,vr9,TARGET_lantiq_xrx200)
 
 define Build/Configure
 endef