ramips: add support for the GnuBee Personal Cloud One
authorL. D. Pinney <ldpinney@gmail.com>
Sat, 22 Jul 2017 01:15:56 +0000 (09:15 +0800)
committerMathias Kresin <dev@kresin.me>
Tue, 25 Jul 2017 19:02:53 +0000 (21:02 +0200)
    The GnuBee Personal Cloud One crowdfunded on https://www.crowdsupply.com
    It is a low-cost, low-power, network-attached storage device.

    Specifications:

    - SoC: MediaTek MT7621AT
    - RAM: DDR3 512 MB
    - Flash: 32 MB
    - Six SATA ports for 2.5" Drives
    - One micro SDcard
    - One USB 3.0
    - Two USB 2.0
    - Gigabit Ethernet: 1 x WAN and 1 x LAN
    - UART 3.5mm Audio Jack or 3 pin header - 57600 8N1
    - Four GPIOs available on a pin header

    Flash instructions:

    The GnuBee Personal Cloud One ships with libreCMC installed.
    libreCMC is a Free Software Foundation approved fork of LEDE/OpenWrt.
    As such one can upgrade using the webinterface or sysupgrade.

    Das U-Boot has multiple options for recovery or updates including :

    - USB
    - http
    - tftp

Signed-off-by: L. D. Pinney <ldpinney@gmail.com>
[use switchdev led trigger, all interfaces are in vlan1; rename leds
according to board.d setting; remove ge2 group from the pinmux, this
group doesn't exist in the driver]
Signed-off-by: Mathias Kresin <dev@kresin.me>
target/linux/ramips/base-files/etc/board.d/01_leds [changed mode: 0755->0644]
target/linux/ramips/base-files/etc/board.d/02_network
target/linux/ramips/base-files/etc/diag.sh
target/linux/ramips/base-files/lib/ramips.sh
target/linux/ramips/base-files/lib/upgrade/platform.sh
target/linux/ramips/dts/GB-PC1.dts [new file with mode: 0644]
target/linux/ramips/image/mt7621.mk

old mode 100755 (executable)
new mode 100644 (file)
index 8ea4645..8678a77
@@ -183,6 +183,10 @@ fonera20n)
        set_usb_led "$board:orange:usb"
        set_wifi_led "$board:orange:wifi"
        ;;
+gb-pc1)
+       ucidef_set_led_switch "lan1" "lan1" "$board:green:lan1" "switch0" "0x01"
+       ucidef_set_led_switch "lan2" "lan2" "$board:green:lan2" "switch0" "0x10"
+       ;;
 gl-mt300a|\
 gl-mt300n|\
 gl-mt750)
index 2d8a90cd3e3cfa7a1d86d0e5464f0d08073d8386..ee769b5a0f32e0c4fae6305952f7fda5f3c7f7bf 100755 (executable)
@@ -186,6 +186,10 @@ ramips_setup_interfaces()
                ucidef_add_switch "switch0" \
                        "1:lan:4" "2:lan:3" "3:lan:2" "4:lan:1" "0:wan" "6@eth0"
                ;;
+       gb-pc1)
+               ucidef_add_switch "switch0" \
+                       "0:lan" "4:lan" "6@eth0"
+               ;;
        gl-mt300n-v2)
                ucidef_add_switch "switch0" \
                        "1:lan" "0:wan" "6@eth0"
index 3933357aad8378f6e7bc815fae361c35fcb4771b..f5c0e835c01cf2baf15ba43ab84d385d7d5a0beb 100644 (file)
@@ -77,6 +77,7 @@ get_status_led() {
        dir-620-a1|\
        dir-620-d1|\
        dwr-512-b|\
+       gb-pc1|\
        hpm|\
        hw550-3g|\
        mac1200rv2|\
index 0fd871a5d60b0ed3bdd7f7b9efb92e11f53ed198..685ba070da391edc3f7dfdb753c992ef7d7f6dee 100755 (executable)
@@ -208,6 +208,9 @@ ramips_board_detect() {
        *"FreeStation5")
                name="freestation5"
                ;;
+       *"GB-PC1")
+               name="gb-pc1"
+               ;;
        *"GL-MT300A")
                name="gl-mt300a"
                ;;
index 830e129115cb16d47a0f65d8c05d475b30440fa0..b087d993b74e6cd923e09cb836b01f0cc903208b 100755 (executable)
@@ -59,6 +59,7 @@ platform_check_image() {
        firewrt|\
        fonera20n|\
        freestation5|\
+       gb-pc1|\
        gl-mt300a|\
        gl-mt300n|\
        gl-mt750|\
diff --git a/target/linux/ramips/dts/GB-PC1.dts b/target/linux/ramips/dts/GB-PC1.dts
new file mode 100644 (file)
index 0000000..df7caa9
--- /dev/null
@@ -0,0 +1,120 @@
+/dts-v1/;
+
+#include "mt7621.dtsi"
+
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/input/input.h>
+
+/ {
+       compatible = "gnubee,gb-pc1", "mediatek,mt7621-soc";
+       model = "GB-PC1";
+
+       memory@0 {
+               device_type = "memory";
+               reg = <0x0 0x1c000000>, <0x20000000 0x4000000>;
+       };
+
+       chosen {
+               bootargs = "console=ttyS0,57600";
+       };
+
+       palmbus: palmbus@1E000000 {
+               i2c@900 {
+                       status = "okay";
+               };
+       };
+
+       gpio-keys-polled {
+               compatible = "gpio-keys-polled";
+               #address-cells = <1>;
+               #size-cells = <0>;
+               poll-interval = <20>;
+
+               reset {
+                       label = "reset";
+                       gpios = <&gpio0 18 GPIO_ACTIVE_HIGH>;
+                       linux,code = <KEY_RESTART>;
+               };
+       };
+
+       gpio-leds {
+               compatible = "gpio-leds";
+
+               system {
+                       label = "gb-pc1:green:system";
+                       gpios = <&gpio0 6 GPIO_ACTIVE_LOW>;
+               };
+
+               status {
+                       label = "gb-pc1:green:status";
+                       gpios = <&gpio0 8 GPIO_ACTIVE_LOW>;
+               };
+
+               lan1 {
+                       label = "gb-pc1:green:lan1";
+                       gpios = <&gpio0 24 GPIO_ACTIVE_LOW>;
+               };
+
+               lan2 {
+                       label = "gb-pc1:green:lan2";
+                       gpios = <&gpio0 25 GPIO_ACTIVE_LOW>;
+               };
+       };
+};
+
+&sdhci {
+       status = "okay";
+};
+
+&spi0 {
+       status = "okay";
+
+       m25p80@0 {
+               #address-cells = <1>;
+               #size-cells = <1>;
+               compatible = "jedec,spi-nor";
+               reg = <0>;
+               spi-max-frequency = <10000000>;
+               m25p,chunked-io = <32>;
+
+               partition@0 {
+                       label = "u-boot";
+                       reg = <0x0 0x30000>;
+                       read-only;
+               };
+
+               partition@30000 {
+                       label = "u-boot-env";
+                       reg = <0x30000 0x10000>;
+                       read-only;
+               };
+
+               factory: partition@40000 {
+                       label = "factory";
+                       reg = <0x40000 0x10000>;
+                       read-only;
+               };
+
+               partition@50000 {
+                       label = "firmware";
+                       reg = <0x50000 0x1fb0000>;
+               };
+       };
+};
+
+&pcie {
+       status = "okay";
+};
+
+&ethernet {
+       mtd-mac-address = <&factory 0xe000>;
+};
+
+&pinctrl {
+       state_default: pinctrl0 {
+               gpio {
+                       ralink,group = "wdt", "rgmii2", "uart3";
+                       ralink,function = "gpio";
+               };
+       };
+};
index bf0e292286ba34835f9226a4948499ae5a242119..a67facb83bd76b0206dbc05580adc660d155c2e1 100644 (file)
@@ -75,6 +75,14 @@ define Device/firewrt
 endef
 TARGET_DEVICES += firewrt
 
+define Device/gb-pc1
+  DTS := GB-PC1
+  DEVICE_TITLE := GnuBee Personal Cloud One
+  DEVICE_PACKAGES := kmod-ata-core kmod-ata-ahci kmod-usb3 kmod-sdhci-mt7620
+  IMAGE_SIZE := $(ralink_default_fw_size_32M)
+endef
+TARGET_DEVICES += gb-pc1
+
 define Device/hc5962
   DTS := HC5962
   BLOCKSIZE := 128k