gcc: remove support for libgcj/java
authorFelix Fietkau <nbd@nbd.name>
Thu, 2 Nov 2017 13:16:20 +0000 (14:16 +0100)
committerFelix Fietkau <nbd@nbd.name>
Thu, 2 Nov 2017 14:58:45 +0000 (15:58 +0100)
It has been removed in gcc 7

Signed-off-by: Felix Fietkau <nbd@nbd.name>
toolchain/gcc/Config.in
toolchain/gcc/common.mk

index ea33ac29c17a20f872bc11a97c0c90bff490867e..a54c8d12d36c47d29a7cc236f2dbc88bab635d14 100644 (file)
@@ -54,14 +54,6 @@ config SJLJ_EXCEPTIONS
            frame unwinding exceptions handling routines.  Warning: increases
            code size and runtime memory usage.
 
-config INSTALL_LIBGCJ
-       bool
-       prompt "Build/install java compiler and GNU classpath ?" if TOOLCHAINOPTS
-       default n
-       help
-           Build/install java compiler and GNU classpath ?
-
-
 config INSTALL_GFORTRAN
        bool
        prompt "Build/install fortran compiler?" if TOOLCHAINOPTS
index d7e205a0119a2af057bd94ac7bffa4d2ed596ae3..f22b8adc2a91225c57deb8bbc7626956683fb7ca 100644 (file)
@@ -74,14 +74,11 @@ HOST_STAMP_CONFIGURED:=$(GCC_BUILD_DIR)/.configured
 HOST_STAMP_INSTALLED:=$(HOST_BUILD_PREFIX)/stamp/.gcc_$(GCC_VARIANT)_installed
 
 SEP:=,
-TARGET_LANGUAGES:="c,c++$(if $(CONFIG_INSTALL_LIBGCJ),$(SEP)java)$(if $(CONFIG_INSTALL_GFORTRAN),$(SEP)fortran)$(if $(CONFIG_INSTALL_GCCGO),$(SEP)go)"
+TARGET_LANGUAGES:="c,c++$(if $(CONFIG_INSTALL_GFORTRAN),$(SEP)fortran)$(if $(CONFIG_INSTALL_GCCGO),$(SEP)go)"
 
 TAR_OPTIONS += \
        --exclude-from='$(CURDIR)/../exclude-testsuite' --exclude=gcc/ada/*.ad* \
-
-ifndef CONFIG_INSTALL_LIBGCJ
-  TAR_OPTIONS += --exclude=libjava
-endif
+       --exclude=libjava
 
 export libgcc_cv_fixed_point=no
 ifdef CONFIG_USE_UCLIBC