oxnas: put u-boot images into image staging directory
authorJo-Philipp Wich <jo@mein.io>
Fri, 27 Jan 2017 15:21:17 +0000 (16:21 +0100)
committerJo-Philipp Wich <jo@mein.io>
Fri, 27 Jan 2017 15:53:31 +0000 (16:53 +0100)
Do not put the u-boot images into the kernel build directory as this directory
might get removed after kernel updates while the u-boot packages InstallDev
recipe is not getting re-executed because it is still considered current,
leading to image build failures later on due to missing images.

To ensure that built bootloader images persist over kernel version updates in
the buildroot, put them into the new STAGING_DIR_IMAGE directory.

Signed-off-by: Jo-Philipp Wich <jo@mein.io>
package/boot/uboot-oxnas/Makefile
target/linux/oxnas/image/Makefile

index 32ee107e7bed4f77ddc64c8e29ca8e2802a0e3f1..daa266ea8cd5f19a93f35a1f79be775b1c6db085 100644 (file)
@@ -29,8 +29,8 @@ endef
 UBOOT_TARGETS:=ox820
 
 define Build/InstallDev
-       $(CP) $(PKG_BUILD_DIR)/u-boot.bin \
-               $(KERNEL_BUILD_DIR)/u-boot.bin
+       $(INSTALL_DIR) $(STAGING_DIR_IMAGE)
+       $(CP) $(PKG_BUILD_DIR)/u-boot.bin $(STAGING_DIR_IMAGE)/u-boot.bin
 endef
 
 $(eval $(call BuildPackage/U-Boot))
index 7ad05844cc992899f5ee64e9814c86893ad15083..bfa0f0cca7fdc4fc03d4321417a3af37440c9426 100644 (file)
@@ -15,7 +15,7 @@ DEVICE_VARS += DTS UBIFS_OPTS
 KERNEL_LOADADDR := 0x60008000
 
 define Build/ubootable
-       (dd if="$(KDIR)/u-boot.bin" bs=128k conv=sync; \
+       (dd if="$(STAGING_DIR_IMAGE)/u-boot.bin" bs=128k conv=sync; \
         dd if="$@" bs=128k conv=sync ) >> $@.new
        @mv "$@.new" "$@"
 endef