ramips: add support for Zbtlink ZBT-WE2026
authorVaclav Svoboda <svoboda@neng.cz>
Wed, 15 Mar 2017 08:37:05 +0000 (09:37 +0100)
committerMathias Kresin <dev@kresin.me>
Fri, 17 Mar 2017 07:58:50 +0000 (08:58 +0100)
This patch adds support for the Zbtlink ZBT-WE2026.

Specification:
- SoC: MediaTek MT7620N (580MHz)
- RAM: 64 MiB
- Flash: 8 MiB SPI
- LAN: 4x100M
- WAN: 1x100M

Installation through bootloader webserver:
- With the power unplugged press and hold reset button.
- Plug power and hold reset button until LED starts to blink.
- Install sysupgrade image using web interface on 192.168.1.1.

Signed-off-by: Vaclav Svoboda <svoboda@neng.cz>
target/linux/ramips/base-files/etc/board.d/01_leds
target/linux/ramips/base-files/etc/board.d/02_network
target/linux/ramips/base-files/etc/diag.sh
target/linux/ramips/base-files/lib/ramips.sh
target/linux/ramips/base-files/lib/upgrade/platform.sh
target/linux/ramips/dts/ZBT-WE2026.dts [new file with mode: 0644]
target/linux/ramips/image/mt7620.mk

index 74ffeabca367fdd286297e8943c9fe015c18e500..4073d803f2f428bd5f4aadf792d575374cdacae8 100755 (executable)
@@ -385,6 +385,9 @@ zbt-wa05)
        set_wifi_led "$board:blue:air"
        set_usb_led "$board:blue:usb"
        ;;
+zbt-we2026)
+       set_wifi_led "$board:green:wlan"
+       ;;
 zbt-we826)
        ucidef_set_led_default "power" "power" "$board:green:power" "1"
        set_wifi_led "$board:green:wifi"
index bbfa269db73ad66ee34dafbbc76b35e752a14790..84564c944fefebb124b3b4da780c35b14122884d 100755 (executable)
@@ -107,6 +107,7 @@ ramips_setup_interfaces()
        y1|\
        youku-yk1|\
        zbt-ape522ii|\
+       zbt-we2026|\
        zbt-we826|\
        zbt-wg2626|\
        zbt-wg3526|\
index 51c0640105513e1d0313e60cadedf18973ca0e5a..3dbf87ac5d4af12045db2c5aee3890a9e52b0d61 100644 (file)
@@ -238,7 +238,8 @@ get_status_led() {
                status_led="$board:amber:power"
                ;;
        whr-g300n|\
-       wlr-6000)
+       wlr-6000|\
+       zbt-we2026)
                status_led="$board:red:power"
                ;;
        wzr-agl300nh)
index 6002362d1900ed6f35781bf1c13514304e691f52..786aecb99b62d26fe978521e46fda8ec89264b42 100755 (executable)
@@ -646,6 +646,9 @@ ramips_board_detect() {
        *"ZBT-WA05")
                name="zbt-wa05"
                ;;
+       *"ZBT-WE2026")
+               name="zbt-we2026"
+               ;;
        *"ZBT-WE826")
                name="zbt-we826"
                ;;
index 90eb6e447d3a887ffe7961b3cba8e372f31f6354..08fa45ad98b5b4c588ca2bfc76bed849f424682b 100755 (executable)
@@ -181,6 +181,7 @@ platform_check_image() {
        zbt-ape522ii|\
        zbt-cpe102|\
        zbt-wa05|\
+       zbt-we2026|\
        zbt-we826|\
        zbt-wg2626|\
        zbt-wg3526|\
diff --git a/target/linux/ramips/dts/ZBT-WE2026.dts b/target/linux/ramips/dts/ZBT-WE2026.dts
new file mode 100644 (file)
index 0000000..02f3378
--- /dev/null
@@ -0,0 +1,103 @@
+/dts-v1/;
+
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/input/input.h>
+
+#include "mt7620n.dtsi"
+
+/ {
+       compatible = "zbtlink,zbt-we2026", "ralink,mt7620n-soc";
+       model = "Zbtlink ZBT-WE2026";
+
+       chosen {
+               bootargs = "console=ttyS0,115200";
+       };
+
+       gpio-leds {
+               compatible = "gpio-leds";
+
+               power {
+                       label = "zbt-we2026:red:power";
+                       gpios = <&gpio1 14 GPIO_ACTIVE_LOW>;
+               };
+
+               wlan {
+                       label = "zbt-we2026:green:wlan";
+                       gpios = <&gpio3 0 GPIO_ACTIVE_LOW>;
+               };
+       };
+
+       gpio-keys-polled {
+               compatible = "gpio-keys-polled";
+               #address-cells = <1>;
+               #size-cells = <0>;
+               poll-interval = <20>;
+
+               reset {
+                       label = "reset";
+                       gpios = <&gpio0 1 GPIO_ACTIVE_LOW>;
+                       linux,code = <KEY_RESTART>;
+               };
+       };
+};
+
+&gpio1 {
+       status = "okay";
+};
+
+&gpio3 {
+       status = "okay";
+};
+
+&spi0 {
+       status = "okay";
+
+       en25q64@0 {
+               #address-cells = <1>;
+               #size-cells = <1>;
+               compatible = "jedec,spi-nor";
+               reg = <0>;
+               spi-max-frequency = <10000000>;
+
+               partition@0 {
+                       label = "u-boot";
+                       reg = <0x0 0x30000>;
+                       read-only;
+               };
+
+               partition@30000 {
+                       label = "u-boot-env";
+                       reg = <0x30000 0x10000>;
+                       read-only;
+               };
+
+               factory: partition@40000 {
+                       label = "factory";
+                       reg = <0x40000 0x10000>;
+                       read-only;
+               };
+
+               partition@50000 {
+                       label = "firmware";
+                       reg = <0x50000 0x760000>;
+               };
+       };
+};
+
+&ethernet {
+       mtd-mac-address = <&factory 0x4>;
+       mediatek,portmap = "wllll";
+};
+
+&wmac {
+       ralink,mtd-eeprom = <&factory 0>;
+};
+
+&pinctrl {
+       state_default: pinctrl0 {
+               default {
+                       ralink,group = "i2c", "spi refclk", "wled";
+                       ralink,function = "gpio";
+               };
+       };
+};
index 7122cfdff5b61ad35071e5cd9142cb6fbec56114..016e5acc5906766f14fdf1f4761776e010b7889f 100644 (file)
@@ -467,6 +467,12 @@ define Device/zbt-wa05
 endef
 TARGET_DEVICES += zbt-wa05
 
+define Device/zbt-we2026
+  DTS := ZBT-WE2026
+  DEVICE_TITLE := Zbtlink ZBT-WE2026
+endef
+TARGET_DEVICES += zbt-we2026
+
 define Device/zbt-we826
   DTS := ZBT-WE826
   IMAGE_SIZE := $(ralink_default_fw_size_16M)