sunxi: add build for sopine
authorFan Fan <fkpwolf@gmail.com>
Mon, 19 Mar 2018 09:52:46 +0000 (17:52 +0800)
committerHauke Mehrtens <hauke@hauke-m.de>
Fri, 23 Mar 2018 22:53:20 +0000 (23:53 +0100)
This will generate image for Pine64 Sopine board.

Signed-off-by: Fan Fan <fkpwolf@gmail.com>
package/boot/uboot-sunxi/Makefile
target/linux/sunxi/image/cortex-a53.mk

index 90cf1027073b8353b66c20b2e85067d9c150ac19..5257a41ad240757277e5dc097d9f13636a34570c 100644 (file)
@@ -190,6 +190,15 @@ define U-Boot/pine64_plus
   UENV:=a64
 endef
 
+define U-Boot/sopine_baseboard
+  BUILD_SUBTARGET:=cortexa53
+  NAME:=Sopine Baseboard
+  BUILD_DEVICES:=sun50i-a64-sopine-baseboard
+  DEPENDS:=+PACKAGE_u-boot-sopine_baseboard:arm-trusted-firmware-sunxi
+  UENV:=a64
+endef
+
+
 define U-Boot/orangepi_zero_plus
   BUILD_SUBTARGET:=cortexa53
   NAME:=Xunlong Orange Pi Zero Plus
@@ -226,6 +235,7 @@ UBOOT_TARGETS := \
        orangepi_2 \
        pangolin \
        pine64_plus \
+       sopine_baseboard \
        orangepi_zero_plus
 
 UBOOT_CONFIGURE_VARS += USE_PRIVATE_LIBGCC=yes
index cd103d47d056adb9ffa6dae35ccb946eec7f7a75..344071b94d2f00b805f84c108e9f117e0bf1ff25 100644 (file)
@@ -27,6 +27,16 @@ endef
 
 TARGET_DEVICES += sun50i-a64-pine64-plus
 
+define Device/sun50i-a64-sopine-baseboard
+  DEVICE_TITLE:=Pine64 Sopine
+  SUPPORTED_DEVICES:=pine64,sopine-baseboard
+  SUNXI_DTS:=allwinner/sun50i-a64-sopine-baseboard
+  KERNEL_NAME := Image
+  KERNEL := kernel-bin
+endef
+
+TARGET_DEVICES += sun50i-a64-sopine-baseboard
+
 
 define Device/sun50i-h5-orangepi-zero-plus
   DEVICE_TITLE:=Xunlong Orange Pi Zero Plus