lantiq: enable Netgear DGN1000B image build
authorTino Reichardt <milky-lede@mcmilk.de>
Sun, 26 Feb 2017 20:28:28 +0000 (21:28 +0100)
committerHauke Mehrtens <hauke@hauke-m.de>
Sat, 3 Jun 2017 19:14:07 +0000 (21:14 +0200)
Enable the building of Netgear DGN1000B images. I have an
example device here, but it was not tested currently.
Also WLAN and USB is not ready in the moment.

This is just the proper way, so that developing on this
device is known to be done in the near future.

Signed-off-by: Tino Reichardt <milky-lede@mcmilk.de>
target/linux/lantiq/image/Makefile

index 12763bbdb11974ebd661093b7d03a6c2f2ff650e..572c9b3ca7d38fd4eb2ec5fe97f6f6a035e00686 100644 (file)
@@ -106,6 +106,20 @@ define Device/AVM
   KERNEL := kernel-bin | append-dtb | lzma | eva-image
 endef
 
+ifeq ($(SUBTARGET),ase)
+
+define Device/DGN1000B
+  IMAGE_SIZE := 6000k
+  DEVICE_DTS := DGN1000B
+  DEVICE_TITLE := Netgear DGN1000B
+  DEVICE_PACKAGES := kmod-ltq-adsl-ase kmod-ltq-adsl-ase-mei \
+       kmod-ltq-adsl-ase-fw-b kmod-ltq-atm-ase \
+       ltq-adsl-app ppp-mod-pppoe
+endef
+TARGET_DEVICES += DGN1000B
+
+endif
+
 ifeq ($(SUBTARGET),xway_legacy)
 
 define Device/ARV4520PW