ramips: fix Mercury MAC1200R v2.0 board name
authorMathias Kresin <dev@kresin.me>
Fri, 28 Jul 2017 17:22:55 +0000 (19:22 +0200)
committerMathias Kresin <dev@kresin.me>
Sat, 29 Jul 2017 07:24:32 +0000 (09:24 +0200)
With d2b6bf141662 ("ramips: fix image validation errors") the board
name was changed to fix an image validation error. But this change
wasn't applied to all other files using the board name, which broke
sysupgrade.

Revert this change and use the former board name in the metadata
instead.

Signed-off-by: Mathias Kresin <dev@kresin.me>
target/linux/ramips/base-files/lib/ramips.sh
target/linux/ramips/image/mt7628.mk

index 0267c9df3fecf43fcb82da4f34d36d5ae90e2b10..3efdeda5333c1d4fda079b085b3e5bf6b07c3438 100755 (executable)
@@ -290,7 +290,7 @@ ramips_board_detect() {
                name="m2m"
                ;;
        *"Mercury MAC1200R v2")
-               name="mac1200r-v2"
+               name="mac1200rv2"
                ;;
        *"MicroWRT")
                name="microwrt"
index fbfc37d9865362967dddec5bd4258701e0aff688..693e64f4ddf7d07495df0e008e47c8400e1d4223 100644 (file)
@@ -92,6 +92,7 @@ TARGET_DEVICES += duzun-dm06
 define Device/mac1200r-v2
   DTS := MAC1200RV2
   DEVICE_TITLE := Mercury MAC1200R v2.0
+  SUPPORTED_DEVICES := mac1200rv2
 endef
 TARGET_DEVICES += mac1200r-v2