kirkwood: use image metadata
authorMathias Kresin <dev@kresin.me>
Thu, 28 Dec 2017 08:22:45 +0000 (09:22 +0100)
committerMathias Kresin <dev@kresin.me>
Tue, 9 Jan 2018 21:06:55 +0000 (22:06 +0100)
Append and enforce image metadata. Remove the device specific image
checks, they are replaced by image metadata.

Signed-off-by: Mathias Kresin <dev@kresin.me>
target/linux/kirkwood/base-files/lib/upgrade/platform.sh
target/linux/kirkwood/image/Makefile

index b28ee873b30cc32288b5f32ce87fcae1cf0929ed..dd06aa7f2258a718a324676aa4844f5eb5a377e8 100644 (file)
@@ -1,27 +1,9 @@
 RAMFS_COPY_BIN='fw_printenv fw_setenv'
 RAMFS_COPY_DATA='/etc/fw_env.config /var/lock/fw_printenv.lock'
 
-platform_check_image() {
-       [ "$#" -gt 1 ] && return 1
-       local board="$(board_name)"
-       local magic="$(get_magic_long "$1")"
+REQUIRE_IMAGE_METADATA=1
 
-       case "$board" in
-       "linksys-audi"|\
-       "linksys-viper")
-               [ "$magic" != "27051956" -a "$magic" != "73797375" ] && {
-                       echo "Invalid image type."
-                       return 1
-               }
-               return 0
-               ;;
-       *)
-               nand_do_platform_check $board $1
-               return $?
-               ;;
-       esac
-
-       echo "Sysupgrade is not yet supported on $board."
+platform_check_image() {
        return 1
 }
 
index f52ae7de019660e11f468be16a907407fecfdd88..b75ef9fbb2274110d6f1bd8968e3043aadc23c05 100644 (file)
@@ -22,8 +22,9 @@ define Device/Default
   SUBPAGESIZE := 512
   BLOCKSIZE := 128k
   IMAGES := sysupgrade.bin factory.bin
-  IMAGE/sysupgrade.bin := sysupgrade-tar
+  IMAGE/sysupgrade.bin := sysupgrade-tar | append-metadata
   IMAGE/factory.bin := append-ubi
+  SUPPORTED_DEVICES := $(1)
 endef
 
 define Device/dockstar