image.mk: Generate cpiogz with root-owned files
authorMichal Sojka <sojkam1@fel.cvut.cz>
Tue, 2 May 2017 14:57:18 +0000 (16:57 +0200)
committerJo-Philipp Wich <jo@mein.io>
Sun, 14 May 2017 19:43:17 +0000 (21:43 +0200)
Some files (e.g. /etc/dropbear) need to be owned by root. Add cpio
option to ensure that.

Other image types (at least targz and squashfs) already have this.

Signed-off-by: Michal Sojka <sojkam1@fel.cvut.cz>
include/image.mk

index ad9535d0189c4618c5c1d85d3bbd643508180a3e..3f5b4544e9e31e423cafe804d01727f011eab258 100644 (file)
@@ -277,7 +277,7 @@ endif
 
 ifdef CONFIG_TARGET_ROOTFS_CPIOGZ
   define Image/Build/cpiogz
-       ( cd $(TARGET_DIR); find . | cpio -o -H newc | gzip -9n >$(BIN_DIR)/$(IMG_PREFIX)-rootfs.cpio.gz )
+       ( cd $(TARGET_DIR); find . | cpio -o -H newc -R root:root | gzip -9n >$(BIN_DIR)/$(IMG_PREFIX)-rootfs.cpio.gz )
   endef
 endif