lantiq: fix AVM initramfs image
authorValentin Spreckels <Valentin.Spreckels@Informatik.Uni-Oldenburg.DE>
Sun, 18 Mar 2018 19:27:50 +0000 (20:27 +0100)
committerMathias Kresin <dev@kresin.me>
Sun, 18 Mar 2018 21:22:38 +0000 (22:22 +0100)
Create an initramfs that can be used with the EVA bootloader.

Signed-off-by: Valentin Spreckels <Valentin.Spreckels@Informatik.Uni-Oldenburg.DE>
target/linux/lantiq/image/Makefile

index e52e43c6e59e4dc58c57a3b72617853e03c0d3f7..e6fbc1dbf8b511de2faeee5c0f18743c2b9872f0 100644 (file)
@@ -101,6 +101,7 @@ endef
 
 define Device/AVM
   KERNEL := kernel-bin | append-dtb | lzma | eva-image
+  KERNEL_INITRAMFS := $$(KERNEL)
   IMAGE/sysupgrade.bin := append-kernel | pad-to 64k | append-avm-fakeroot | \
        append-rootfs | pad-rootfs | append-metadata | check-size $$$$(IMAGE_SIZE)
 endef